6.3.4 Setting up the simulation tools

To set up the simulation tools, follow these steps:

  1. Install a minimum version of the following:
    • GNU Make version 3.80.
    • GNU GCC version 4.7.2 or 4.8.3.
    • GNU Binutils 2.22.
  2. Install at least one of the supported Verilog simulators. The recommended minimum versions are:
    • Mentor QuestaSim version 10.4e_1. You will need to set the environment variable QUESTASIM_HOME to reference your QuestaSim installation directory.
    • Cadence IUS version 15.20.008.
    • Synopsys VCS version 2016.06-SP2.

If you need to compile your own test or recompile an example test, install at least one of the supported C compilers. The recommended minimum versions are:

  • ARM Development Studio 5 (DS-5) version 5.06.409.
  • ARM Keil® Microcontroller Development Kit (MDK) version 5.22.
  • GNU Tools for ARM Embedded Processors (ARM GCC) version 5-2016q2.
Non-ConfidentialPDF file icon PDF versionARM 100894_0000_00_en
Copyright © 2017 ARM Limited or its affiliates. All rights reserved.