5.2.2 Menu bar

The main bar provides access to System Canvas functions and commands.

File menu

The File menu lists file and project operations.

New Project

Create a new model project.

Load Project

Open an existing project.

Close Project

Close a project. If there are pending changes, the Save changes dialog appears.

Save Project

Save the changes made to a project.

Save Project As

Save a project to a new location and name.

New File

Create a new file. The New File dialog appears. Select the type from the File type drop-down list.

Open File

This displays the Open File dialog. Filter the types to display by selecting the type from the File type drop-down list. Non-LISA files open as text in the source editor.

Close File

Close a LISA file. A dialog prompts to save any changes.

Save File

Save the changes made to the current LISA file.

Save File As

Save a LISA file to a new location and name.

Save All

Save the changes made to the project and the LISA files.

Print

Print the contents of the Block Diagram window.

Preferences

Modify the user preferences.

Recently Opened Files

Display the 16 most recently opened LISA files. Click on a list entry to open the file.

To remove a file from the list, move the mouse cursor over the filename and press the Delete key or right click and select Remove from list from the context menu.

Recently Opened Projects

Display the 16 most recently opened projects. Click on a list entry to open the project.

To remove a project from the list, move the mouse cursor over the project name and press the Delete key or right click and select Remove from list from the context menu.

Exit

Close System Canvas. A dialog prompts to save any changes. Disable it by selecting Do not show this message again. Re-enable it in the preferences.

Edit menu

The Edit menu lists content operations.

Undo

Undo up to 42 of the latest changes to a file in the Source view or to the layout in the Block Diagram view. These actions are undoable:

  • Add an object such as a component, label, or connection.

  • Paste or duplicate.

  • Cut or delete.

  • Edit object properties.

  • Move.

  • Resize.

Note:

Undo and Redo operations can affect Block Diagram view zoom and scroll actions.

Undo and Redo typically work normally. For example:

  1. Change the system in the Block Diagram view by adding a RAMDevice component with name RAM.

  2. Switch to Source view. The text RAM : RAMDevice(); is present in the composition section.

  3. Change the code by removing the line RAM : RAMDevice();.

  4. Change the code by adding, for example, the line PVS : PVBusSlave();.

  5. Click on the Block Diagram tab. The change to the source code is reflected by the RAM component being replaced by the PVS component.

  6. Select Undo from the Edit menu. The Block Diagram view shows that RAM is present but PVS is not.

  7. Select Redo from the Edit menu. The Block Diagram view shows that PVS is present but RAM is not.

Redo

Redo the last undone change. This cancels the result of selecting Undo. Selecting Redo multiple times cancels multiple Undo actions.

Cut

Cut the marked element into the copy buffer.

Copy

Copy the marked element into the copy buffer.

Paste

Paste the content of the copy buffer at the current cursor position.

Duplicate

Duplicate the marked content.

Delete

Delete the marked element.

Select All

Select all elements.

Edit Mode

Change the Workspace to Edit mode. The cursor can select components.

Connect Ports Mode

Select Connection mode. The cursor can connect components.

Pan Mode

Select Movement mode. The cursor can move the entire system in the Workspace window.

Search menu

The Search menu lists find, replace and go to functions.

Find

Search for a string in the active window (with a thick black frame).

Find Next

Repeat the last search.

Find Previous

Repeat the last search, backwards in the document.

Replace

In the Source view, search for and replace strings in a text document.

Go To Line

In the Source view, specify a line number in the currently open LISA file to go to.

Note:

Use the search icons at the top right of the application window to search for text. Entering text in the search box starts an incremental search in the active window.

View menu

The View menu lists the Workspace window display options.

Show Grid

Using the grid simplifies component alignment.

Zoom In

Show more detail.

Zoom Out

Show more of the system.

Zoom 100%

Change the magnification to the default.

Zoom Fit

Fit the entire system into the canvas area.

Zoom Fit Selection

Fit the selected portion into the canvas area.

Object menu

The Object menu lists system and system component operations.

Open Component

Open the source for the selected component.

Add Component

Display all of the components available for adding to the block diagram.

Add Label

The mouse cursor becomes a default label. To add the label, move it to the required location in the Block Diagram window and click the left mouse button. The Label Properties dialog appears.

Add Port

Display the External Port dialog. Specify the type of port to add.

Mirror Self Port

Switch the direction that the external port image points in. It does not reverse the signal direction, so a master port remains a master port. If an unconnected port is not selected, this option is disabled.

Expand Port

For a port array, display all of the individual port elements. Expanded is the default for port arrays with eight or fewer ports. Collapsed is the default for port arrays with more than eight elements.

Note:

Ports with many elements might expand so that elements appear on top of one another. Either: click and drag them apart, or collapse the port, increase the component size, then expand the port again.

Collapse Port

For a port array, hide the individual port elements and only display the top-level port name.

Hide Port

Disable the selected port and make it invisible.

Hide All Unconnected Ports

Hide all ports that are not connected to a component.

Show/Hide Ports of Protocol Types...

Hide all ports that use a specified protocol. The Show/Hide Connection Types dialog appears. Select the protocols to filter.

Show All Ports

Show all ports. Some might overlap if there is not enough space.

Autoroute Connection

Redraw the selected connection.

Autoroute All Connections

Redraw all of the connections.

Documentation

Open the documentation for the selected component.

Object Properties

Display the Component Instance Properties dialog to view and edit the properties for the selected component.

Project menu

The Project menu lists build, check, configure, run, and set options.

Check System

Check for errors or missing information. This feature does not check everything, but does give useful feedback.

Generate System

Generate the C++ source code, but do not compile it. After generation, click Build System and Debug to run the model.

Build System

Generate and compile the generated C++ source code, producing a library or a runnable model.

Stop Build

Cancel the active build process.

Clean

Delete all generated files.

Launch Model Debugger

Execute the simulation under the control of Model Debugger.

Run
Run...

Open the Run dialog to specify the run command.

Run in Model Shell

Execute the simulation under the control of Model Shell with command-line options taken from project settings and user preferences.

Run ISIM system

Execute the simulation as an ISIM executable with Model Shell command-line options taken from project settings and user preferences.

Clear History

Clear all recent run command entries.

Recent Command Entries (up to 10)

Call recent command entries.

Kill Running Command

Stop the running synchronous command.

Launch Host Debugger
Microsoft Windows

Launch Microsoft Visual Studio. Build the system there, and start a debug session.

Note:

You can take the command-line arguments for ISIM systems or Model Shell from Microsoft Visual Studio by selecting Project > Properties > Configuration Properties > debugging .

Linux

Launch the executable or script set in the application preferences. The target must be an ISIM executable. ARM recommends this method for debugging at source-level.

Add Files

Add files to the system.

Add Current File

Add the currently open file to the system.

Refresh Component List

Update the Component List window to show all available components.

Setup Default Repository

Display the Default Model Repository section of the Preferences window, and select the default repositories for the next new project.

Note:

This does not affect the currently open project.

Set Top Level Component

Displays the Select Top Component dialog that lists all available components in the system.

The top component defines the root component of the system. It can be any component. This enables building of models from subsystems.

Note:

If the value in the Type column is System, the component has subcomponents.

Active Configuration

Select the system build configuration from the project file list.

Project Settings

Display the Project Settings dialog.

Help menu

The Help menu lists documentation, software and system information links.

Fast Model Tools User Guide

Display the Fast Models User Guide.

Model Shell Reference Manual

Display the Model Shell for Fast Models Reference Manual.

LISA+ Language Reference Manual

Display the LISA+ Language for Fast Models Reference Manual.

AMBA-PV Developer Guide

Display the AMBA-PV Extensions to TLM 2.0 Developer Guide.

CADI Developer Guide

Display the Component Architecture Debug Interface v2.0 Developer Guide.

Release Notes

Display this document.

Documents in $PVLIB_HOME/Docs

List the PDF files in the directory $PVLIB_HOME/Docs. The location syntax is the same on Microsoft Windows and Linux. The Fast Models Portfolio installation sets the PVLIB_HOME environment variable.

End User License Agreement (EULA)

Display the license agreement.

About

Display the version and license information.

System Information

Display information about the tools and loaded models.

Non-ConfidentialPDF file icon PDF versionARM 100965_1101_00_en
Copyright © 2014–2017 ARM Limited or its affiliates. All rights reserved.