2.1 Requirements for Fast Models

This section describes the hardware and software that you need for Fast Models.

Platform

Memory
At least 2GB RAM, preferably 4GB.
Processor
2GHz Intel Core2Duo, or similar, that supports the MMX, SSE, SSE2, SSE3, and SSSE3 instruction sets.

Linux

Operating system
Red Hat Enterprise Linux 6 or 7 (for 64-bit architectures), Ubuntu 14.04 Long Term Support (LTS), Ubuntu 16.04 LTS.
Shell
A shell compatible with sh, such as bash or tcsh.
Compiler
gcc 4.8.3, gcc 4.9.2, gcc 5.4.0.

Note:

For full compatibility, it is highly recommended that all code that links against the Fast Models is compiled with C++11 support enabled. There are no known issues when linking non-C++11 code with the Fast Models. However, the compiler does not guarantee that the ABI is the same for both types of code. Compiling models with C++11 support disabled might cause data corruption or other issues when using them.
PDF Reader
Adobe does not support Adobe Reader on Linux. ARM recommends system provided equivalents, such as Evince, instead.
License management utilities

The latest version of the FlexNet software that is available for download from

https://developer.arm.com/products/software-development-tools/license-management/downloads

Note:

  • Set up a single armlmd license server. Spreading Fast Models license features over servers can cause feature denials.
  • To run armlmd and lmgrd, install these libraries:
    Red Hat
    lsb, lsb-linux
    Ubuntu
    lsb

Microsoft Windows

Operating system
Microsoft Windows 7 64-bit RTM or Service Pack 1, Professional, or Enterprise editions, Microsoft Windows 10 64-bit.
Compiler
Microsoft Visual Studio 2013 update 4, Microsoft Visual Studio 2015 update 3.

Note:

For full compatibility, it is highly recommended that all code that links against the Fast Models is compiled with C++11 support enabled. There are no known issues when linking non-C++11 code with the Fast Models. However, the compiler does not guarantee that the ABI is the same for both types of code. Compiling models with C++11 support disabled may cause data corruption or other issues when using them.
PDF Reader
Adobe Reader 8 or higher.
License management utilities

The latest version of the FlexNet software that is available for download from

https://developer.arm.com/products/software-development-tools/license-management/downloads

Note:

  • To build models using Visual Studio requires you to install the Visual Studio redistributable package which contains the runtime libraries for Visual Studio. Fast Models does not provide these libraries. Download the appropriate libraries free of charge from Microsoft:

  • Fast Models does not support Express or Community editions of Visual Studio.
  • Set up a single armlmd license server. Spreading Fast Models license features over servers can cause feature denials.
  • If you use Microsoft Windows Remote Desktop (RDP) to access System Canvas (or a simulation that it generated), your license type can restrict you:
    • Floating licenses require a license server, and have no RDP restrictions. ARM issues them on purchase.
    • Node locked licenses apply to specific workstations. Existing node locked licenses and evaluation licenses do not support running the product over RDP connections. Contact license.support@arm.com for more information.
Non-ConfidentialPDF file icon PDF versionARM 100965_1101_00_en
Copyright © 2014–2017 ARM Limited or its affiliates. All rights reserved.