2.4.1 About Red Hat Enterprise Linux dependencies

Some library objects or applications depend on other library files. Fast Models requires some packages that are part of Red Hat Enterprise Linux, which you might need to install.

If you subscribed your Red Hat Enterprise Linux installation to the Red Hat Network, or if you are using CentOS rather than Red Hat Enterprise Linux, you can install dependencies from the internet. Otherwise, use your installation media.

Some packages might depend on other packages. If you install with the Add/Remove software GUI tool or the yum command line tool, these dependencies resolve automatically. If you install packages directly using the rpm command, you must resolve these dependencies manually.

To display the package containing a library file on your installation, enter:

rpm -qf library_file

For example, to list the package containing /lib/tls/libc.so.6, enter the following on the command line:

rpm -qf /lib/tls/libc.so.6

The following output indicates that the library is in version 2.3.2-95.37 of the glibc package:

glibc-2.3.2-95.37
Non-ConfidentialPDF file icon PDF versionARM 100965_1101_00_en
Copyright © 2014–2017 ARM Limited or its affiliates. All rights reserved.