2.1 Requirements for Fast Models

This section describes the hardware and software that you need for Fast Models.

Platform

Memory
At least 2GB RAM, preferably 4GB.
Processor
2GHz Intel Core2Duo, or similar, that supports the MMX, SSE, SSE2, SSE3, and SSSE3 instruction sets.

Linux

Operating system

Red Hat Enterprise Linux 6 or 7 (for 64-bit architectures), Ubuntu 14.04 Long Term Support (LTS), or Ubuntu 16.04 LTS.

Shell
A shell compatible with sh, such as bash or tcsh.
Compiler
GCC 4.9.2, GCC 5.4.0, GCC 6.4.0.

Note:

For full compatibility, it is highly recommended that all code that links against the Fast Models is compiled with C++11 support enabled. There are no known issues when linking non-C++11 code with the Fast Models. However, the compiler does not guarantee that the ABI is the same for both types of code. Compiling models with C++11 support disabled might cause data corruption or other issues when using them.

The following combinations of GCC and GNU binutils were used to build Fast Models libraries:

Table 2-1 GCC and binutils versions

GCC version GNU binutils version
4.9.2 2.17.50.0.17
5.4.0 2.27
6.4.0 2.27

Note:

Fast Models binaries were built on Red Hat Enterprise Linux 6 and therefore were built against GLIBC 2.12.
PDF Reader
Adobe does not support Adobe Reader on Linux. Arm recommends system provided equivalents, such as Evince, instead.
License management utilities

The latest version of the FlexNet software that is available for download from

https://developer.arm.com/products/software-development-tools/license-management/downloads

Note:

  • Set up a single armlmd license server. Spreading Fast Models license features over servers can cause feature denials.
  • To run armlmd and lmgrd, install these libraries:
    Red Hat
    lsb, lsb-linux
    Ubuntu
    lsb

Microsoft Windows

Operating system
Microsoft Windows 7 64-bit RTM or Service Pack 1, Professional, or Enterprise editions, Microsoft Windows 10 64-bit.
Compiler
Microsoft Visual Studio 2015 update 3, Microsoft Visual Studio 2017 version 15.9.11 or later.
PDF Reader
Adobe Reader 8 or higher.
License management utilities

The latest version of the FlexNet software that is available for download from

https://developer.arm.com/products/software-development-tools/license-management/downloads

Note:

  • To build models using Visual Studio 2015 requires you to install the Visual Studio redistributable package which contains the runtime libraries for Visual Studio. Fast Models does not provide these libraries. Download the libraries for Visual Studio 2015 free of charge from Microsoft, from https://www.microsoft.com/en-gb/download/details.aspx?id=48145.

  • Fast Models does not support Express or Community editions of Visual Studio.
  • Set up a single armlmd license server. Spreading Fast Models license features over servers can cause feature denials.
  • If you use Microsoft Windows Remote Desktop (RDP) to access System Canvas (or a simulation that it generated), your license type can restrict you:
    • Floating licenses require a license server, and have no RDP restrictions. Arm issues them on purchase.
    • Node locked licenses apply to specific workstations. Existing node locked licenses and evaluation licenses do not support running the product over RDP connections. Contact license.support@arm.com for more information.
Non-ConfidentialPDF file icon PDF version100965_1180_00_en
Copyright © 2014–2019 Arm Limited or its affiliates. All rights reserved.