2.1.2 Launching from System Canvas

This section describes how to launch Model Debugger from System Canvas.

Procedure

  1. Open the Debug Simulation dialog box:
    • Click the Debug button on the toolbar.
    • Select main menu > Project > Launch Model Debugger .
    The Debug Simulation dialog box appears.

    Note:

    If you have loaded a model, the CADI library option and the Application field are available for use.

    Figure 2-1 Debug Simulation dialog box
    Debug Simulation dialog box


  2. Click OK.
    Model Debugger starts.

Using the Configure Model Parameters dialog box

This section describes how to configure models.

If you had not yet loaded a model at the time that Model Debugger starts:

  1. Select File > Load Model.

  2. In the Load Model dialog box that appears, locate and select the required model, then click Open.

  3. A dialog box appears:

Figure 2-2 Configure Model Parameters dialog box
Configure Model Parameters dialog box


If you had already loaded a model before Model Debugger starts, Model Debugger checks the available components and opens a similar dialog box.

Note:

The exact contents and titles of the panes might differ because they depend on the model.

The Configure Model Parameters dialog box has the following sections:

Parameter category

This pane contains a hierarchical list of the component parameters by category. To expand the view, click the + symbol. To collapse the view, click the - symbol.

Parameter setting

The parameter values are displayed in the right-hand pane.

To toggle between hexadecimal or decimal views, use the box in the lower left corner of the window.

Note:

The name of this pane varies, depending on the model, but its purpose and usage is the same in all cases.

To view the configuration parameters as a single list, click the List View tab. The Tree View is similar, but shows the same parameters in a grouped hierarchy.

Figure 2-3 Configure Model Parameters dialog box, List View tab
Configure Model Parameters dialog box, List View tab


Set the parameters for the model and click OK to close the Configure Model Parameters dialog box.

Using the Select Targets dialog box

After closing the Configure Model Parameters dialog box, the Select Targets dialog box appears. Select those components that can be debugged in the model.

Figure 2-4 Select Targets dialog box
Select Targets dialog box


  1. Click the box next to the components that are to load.

  2. The Application file column displays applications to load for the processors. If the correct application is not selected, click in the field and enter the name of the source file.

  3. If the application name in the list is the same as the application that was already loaded, the debug information is automatically loaded to the debugger.

  4. Click OK to close the dialog box.

  5. One or more instances of Model Debugger are created, depending on how many targets you selected to load.

    If the application is loaded and the source code can be found from the debug information in the specified file, Model Debugger displays the code in the source window.

    If the debug information cannot be found because, for example, the Application file field is empty, use the Load Application dialog box to specify the location for the source code.

Using the Load Application dialog box

If the application and source code are not loaded automatically, select File > Load Application to locate and load the code manually.

Figure 2-5 Load Application dialog box
Load Application dialog box


Reset the component after loading the source.

Note:

The Load Application dialog box only displays if you have loaded a model from Model Debugger.
Non-ConfidentialPDF file icon PDF version100968_1103_00_en
Copyright © 2014–2018 Arm Limited (or its affiliates). All rights reserved.