2.2.3 Menu bar

The main menu bar provides access to most Model Debugger functions and commands.

File menu

The File menu has the following options:

Open Source …

Opens the source code for the application.

Source File Manager …

Displays the Source File Manager dialog box.

Load Application Code …

Loads application code to the model.

Load Application Code (Debug info only) …

Loads debug information only.

Load Model …

Loads a model.

Connect to Model …

Displays the Connect to Target dialog box to connect to a model file.

Debug Isim System …

Displays the Debug Isim System dialog box to start and debug an isim system.

Debug SystemC Simulation …

Displays the Debug SystemC Simulation dialog box to start and debug a SystemC simulation.

Close Model

Closes the currently open model. If Model Debugger is connected to a CADI server, the connection is closed but the simulation continues to run.

Open Session …

Opens a previously saved session.

Save Session

Saves the current debug session.

Save Session As

Saves the current debug session to a new location and name.

Preferences

Displays the Preferences dialog box to enable you to modify the user preferences.

Recently Opened Models

Displays a list of the most recently opened model files. To open the file, click a list entry. By default, the last 16 files are displayed in the list. The number of files to display can be set in the Preferences dialog box.

To remove a file from the list, move the mouse cursor over the file name. Press the Delete key or right click and select Remove from list from the context menu.

Recently Opened Applications

Displays a list of the most recently opened applications. To open the application, click a list entry. By default, the last 16 applications are displayed in the list. The number of applications to display can be set in the Preferences dialog box.

To remove an application from the list, move the mouse cursor over the application name. Press the Delete key or right click and select Remove from list from the context menu.

Recently Opened Sessions

Displays a list of the most recently opened sessions. To open the session, click a list entry. By default, the last 16 sessions are displayed in the list. The number of sessions to display can be set in the Preferences dialog box.

To remove a session from the list, move the mouse cursor over the session name. Press the Delete key or right click and select Remove from list from the context menu.

Exit

Ends Model Debugger. If you have modified files or sessions, a dialog box prompts you to save your changes.

Search menu

The Search menu has the following options:

Find …

Opens a dialog box that enables searching for a string in a currently active window.

Find Next

Repeats the last defined search to find the next occurrence.

Find Previous

Repeats the last defined search, but the search direction is backwards in the document.

Control menu

The Control menu has the following options:

Note:

When using options that reset the model, Arm recommends the syncLevel should be 1 or higher, for best results.
Hard Reset

This option resets the target model without reloading the application.

Reset

Click to cause a reset of the target model. The application is reloaded automatically.

Goto Main

Cause a reset of the target model. The application is reloaded. The model runs until the main() function of the application source code is reached.

Note:

This command is only available if a function main() can be found in the debug information of the application file.
Run

Run the simulation until a breakpoint is hit or some exception occurs. An example would be simulation halt.

Pause/Continue Source Step

Pause or continue the current high-level simulation step command. An example would be a source-level step.

Source Step Over

Cause a source-level step to execute until the simulation reaches a different source line.

Source Step Out

Cause source-level steps to execute control command until the current function is exited.

Instruction Step

Advance the simulation by executing one source-level instruction.

Instruction Step Over

Advance the simulation by one source-level instruction without following any call instructions.

Note:

Not all model targets support this command.
Instruction Step Out

Advance the simulation until a return instruction is executed.

Note:

Not all model targets support this command.
Instruction Step n

Advance the simulation by the number of instructions in the <- n -> edit box. The default is 1000 cycles.

Cycle Step

Advance the simulation by a single cycle.

Cycle Step n

Advance the simulation by the number of cycles in the edit box. The default is 1000 cycles.

Enable/Disable Step Back

Enable or disable stepping back by cycles.

Note:

Not all model targets support this command.
Back

Step the simulation backwards by one cycle.

Note:

Not all model targets support this command.
Back n

Step the simulation backwards by the number of cycles in the edit box. The default is 1000 cycles.

Note:

Not all model targets support this command.
Configure cores for MP stepping …

To enable independent execution of cores, that is, targets, use the Configure cores for MP stepping dialog box.

Figure 2-11 Configure cores for MP stepping dialog box
Configure cores for MP stepping dialog box


In cluster (multiprocessor) debugging, each Model Debugger window is connected to a particular target, and the controls in that window apply only to that target. It is the simulation that determines how other connected targets behave when you click Stop, Step, or Run within a window. Typical behavior is to stop and run the whole simulation.

You use the Configure cores for MP stepping dialog box to enable Model Debugger to override the default behavior. Model Debugger can control each target to which it is connected. It can force that target to stop executing code while the simulation is running or stepping. In that instance, Model Debugger does not stop any target to which it is not connected. To stop during independent stepping, connect to a target, even if you do not specifically want to view or control that target.

Note:

The Configure cores for MP stepping dialog box is only enabled if you have loaded a model.

The available MP stepping modes are as follows:

  • Use Default - step whole simulation to place all execution control with the simulator. In this mode, Model Debugger does not explicitly stop any targets.

  • Foreground core only - other attached targets are stopped enables the foreground target to run, and to stop all other targets to which it is connected.

    Note:

    The foreground target is the target that is associated with the window that you have selected to run.
  • Custom - single-step selected targets together enables a fixed set of targets to run, and to stop all other targets to which Model Debugger is connected. This mode disables step and run controls for deselected targets.

Debug menu

The Debug menu has the following options:

Display Messages

Display debug messages.

Clear Log

Clear the log of debug messages.

Clear Model Output

Clears all output messages from the model.

Clear Output Summary

Clear the summary output messages.

Breakpoint Manager …

Display the Breakpoint Manager dialog box.

Profiling Manager …

Display the Profiling Manager dialog box.

Note:

Fast Models does not use the profiling options.
View Profiling …

Display the Profile Information dialog box.

Note:

Fast Models does not use the profiling options.
Save Model State …

Save the current model state. If reloaded, simulation continues from the point where the model state was saved.

Restore Model State …

Reload a previously saved model state.

Load Debug Info for Module

Load debug information for the module.

Set Parameters

Set parameter values for the model.

Select Targets

Select the execution target within the model.

Layout menu

The Layout menu has the following options:

Layout Control Window

To set layout options such as tiling, display this window.

Load Layout …

Load a previously saved window layout.

Save Layout …

Save the current layout. Model state is not saved.

Load Recent Layout

Use a recently used window layout.

Restore Default Layout

Restore the window layout to the defaults. This option is useful if the layout has become disorganized.

Window menu

The Window menu has the following options:

New View

Display a new debug view.

Hide

Hide an existing debug view.

Show

Display view that was most recently hidden.

Show All

Displays all previously hidden views.

Close

Close the window in focus.

Arrange Horizontally

Tile all view windows horizontally.

Arrange Vertically

Tile all view windows vertically.

Move

Move a view to the new position specified on the submenu.

Docked Views

Dock or undock the view list on the submenu.

Help menu

The Help menu has the following options:

Help …

Opens this book in Adobe Acrobat Reader.

About …

Displays the standard About dialog box displaying version and license information.

About Model …

Opens the text file that contains the release notes.

Non-ConfidentialPDF file icon PDF version100968_1180_00_en
Copyright © 2014–2019 Arm Limited or its affiliates. All rights reserved.