CADI Client Integration Kit 2.0 Release Notes
(version 2.0.0104 dated 2012/12/07 14/11/2012)

Software requirements for Linux

Operating system: Redhat Enterprise Linux 4 and 5 (on either 32 bit or 64 bit architecture).

Compiler: The CADI Client Integration Kit 2.0 supports gcc 3.4.3. The gcc toolchain must be 32 bit, even if running on 64 bit architecture.

To view the documentation, Adobe Acrobat or Reader needs to be installed on the system.

Software requirements for Windows

Operating system: Microsoft Windows XP and Vista (running on 32 or 64 bit hardware).

Compiler: Microsoft Visual Studio .NET 2003, .NET 2005 with Service Pack 1, or .NET 2008 with Service Pack 1.

To view the documentation, Adobe Acrobat or Reader needs to be installed on the system.

New features and bug fixes since CADI Client Integration Kit 2.0.009

CADI Client Library

- Fixed CADI server detection under Win Vista 64 bit (DE715551)

- Fixed crashes on remote shutdown and disconnection (DE714652, DE661167)

- Significant speed up of CADI client/server connection (DE687669, DE638986)

Model Shell (since Model Shell 4.0.016)

- model_shell does not crash any more when terminated by Ctrl-C while the application waits for input.

- model_shell does not crash any more if connected debugger calls CADISimulation::Release(true) in order to close the simulation.

- Speeded up remote connection via CADI server/client significantly

- Model Shell no longer fails to read a config file if it doesn't end in a linebreak (DE 684870).