19.2.2. Software requirements

The software required to run the ARMv8-A Foundation Platform is as follows:

Operating Systems
  • Red Hat Enterprise Linux version 5.x for 64-bit Intel architectures.

  • Red Hat Enterprise Linux version 6.x for 64-bit Intel architectures.

  • Ubuntu 10.04 or later for 64-bit Intel architectures.

Note

At present, there is no support for running the platform on other operating systems. However, the model should run on any recent x86 64-bit Linux OS provided glibc v2.3.2, or higher, and libstdc++ 6.0.0, or higher, are present.

UART Output

For the Universal Asynchronous Receiver/Transmitter (UART) output to be visible, both xterm and telnet must be installed on the host, and be specified in your PATH.

Copyright © 2015 ARM. All rights reserved.ARM DEN0024A
Non-ConfidentialID050815