ARM® Profiler 2.0
Installation Guide for Windows and Red Hat Linux
Copyright © 2008 ARM Limited. All rights reserved.

Release Information
The following changes have been made to this book.

<table>
<thead>
<tr>
<th>Date</th>
<th>Issue</th>
<th>Confidentiality</th>
<th>Change</th>
</tr>
</thead>
<tbody>
<tr>
<td>October 2007</td>
<td>A</td>
<td>Non-Confidential</td>
<td>RealView Profiler Release v1.0</td>
</tr>
<tr>
<td>September 2008</td>
<td>B</td>
<td>Non-Confidential</td>
<td>ARM Profiler Release v2.0</td>
</tr>
</tbody>
</table>

Proprietary Notice

Words and logos marked with ™ or ® are registered trademarks or trademarks owned by ARM Limited. Other brands and names mentioned herein may be the trademarks of their respective owners.

Neither the whole nor any part of the information contained in, or the product described in, this document may be adapted or reproduced in any material form except with the prior written permission of the copyright holder.

The product described in this document is subject to continuous developments and improvements. All particulars of the product and its use contained in this document are given by ARM in good faith. However, all warranties implied or expressed, including but not limited to implied warranties of merchantability, or fitness for purpose, are excluded.

This document is intended only to assist the reader in the use of the product. ARM Limited shall not be liable for any loss or damage arising from the use of any information in this document, or any error or omission in such information, or any incorrect use of the product.

Where the term ARM is used it means "ARM or any of its subsidiaries as appropriate".

Confidentiality Status

This document is Non-Confidential. The right to use, copy and disclose this document may be subject to license restrictions in accordance with the terms of the agreement entered into by ARM and the party that ARM delivered this document to.

Unrestricted Access is an ARM internal classification.

Product Status

The information in this document is final, that is for a developed product.

Web Address

http://www.arm.com

Contents

Supported platforms .....................................................................................................................................2
Installing ARM Profiler on Windows ..............................................................................................................3
Installing ARM Profiler on Red Hat Linux .....................................................................................................4
Installing ARM Profiler from the command line .............................................................................................6
Setting up ARM Profiler for hardware profiling ............................................................................................8
Getting Started with ARM Profiler using the xvid example ...........................................................................9
1 Supported platforms

ARM Profiler v2.0 is supported on:

- Microsoft Windows
- Red Hat Enterprise Linux

--- Note ---

ARM Profiler v2.0 uses FLEXnet license management software. To use floating licenses, TCP/IP networking must be configured and running on every relevant computer. See the *ARM FLEXnet License Management Guide v4.1* for more information.

1.1 Microsoft Windows

ARM Profiler v2.0 is supported on machines running the following Windows operating systems:

- Windows XP Professional, 32 or 64-bit, with service pack 2 installed
- Windows Vista Business, 32 or 64-bit, with service pack 1 installed
- Windows Vista Enterprise, 32 or 64-bit, with service pack 1 installed

1.2 Red Hat Enterprise Linux

ARM Profiler v2.0 is supported on Pentium IBM-compatible machines running the following versions of Red Hat Linux:

- Red Hat Enterprise Linux WS version 4 for Intel x86 (32-bit and 64-bit) using GNOME Window Manager and Bash Shell
- Red Hat Enterprise Linux WS version 5 for Intel x86 (32-bit and 64-bit) using GNOME Window Manager and Bash Shell
2 Installing ARM Profiler on Windows

To install ARM Profiler v2.0, you can:

- use the ARM RealView Software Wizard, and follow the on-screen prompts.
- run the command-line installer, which is useful for installing from a batch file for unattended installations (see Installing ARM Profiler from the command line on page 6).

2.1 Installing with the ARM RealView Software Wizard

To install ARM Profiler v2.0:

1. Insert the CD into the CD-ROM drive.
   The ARM RealView Software Wizard starts automatically. If it does not start, run the program setup.exe in the top-level directory of the CD-ROM.

2. Follow the instructions to install ARM Profiler.

   ——— Note ————

   You can set up or modify the environment variables after the installation is complete by using the arment tool (see the RealView Development Suite Getting Started Guide for more details).

3. When the software installation is complete, the ARM License Wizard is launched. If you already have a network FLEXnet license server set up and running, or if you want to defer installing a license to a later time, click Cancel. Otherwise, follow the prompts to install your license file or go to the ARM licensing website to obtain a license.

2.2 Modifying or uninstalling ARM Profiler

To modify or uninstall ARM Profiler:

1. Make sure that no RealView Development Suite component is running before you start.

2. Select Start → All Programs → ARM → Uninstall Wizard to launch the ARM RealView Software Wizard.

3. Follow the instructions.

4. On the Component choice panel, check the box next to ARM Profiler 2.0 and click Next. Make sure that only the applications that you want to modify are checked.

   ——— Note ————

   In addition to the ARM → Uninstall Wizard menu option, you can use the ARM → ARM Profiler v2.0 → Uninstall menu option to uninstall only ARM Profiler.
3 Installing ARM Profiler on Red Hat Linux

To install ARM Profiler v2.0, you can:

• use the ARM RealView Software Wizard, and follow the on-screen prompts.
• run the command-line installer, which is useful for installing from a script for unattended installations (see Installing ARM Profiler from the command line on page 6).

3.1 Installing with the ARM RealView Software Wizard

To install ARM Profiler v2.0:

1. Insert the CD into the CD-ROM drive.
   
   **Note**
   
   Do not install as root, or other privileged user. If you do, then configuration files that might have to be modified by other RealView components (such as RealView ICE) cannot be changed, and can cause configuration failures.

2. If the CD does not automount, log in as root and mount it by typing:

   ```
   mount device mount-dir
   ```

   where `device` is the path of your CD-ROM device, for example `/dev/cdrom`, and `mount-dir` is the path to an existing directory where the CD-ROM is to be mounted, for example, `/mnt/cdrom`

3. Move to the top-level CD-ROM directory. For example:

   ```
   cd /mnt/cdrom
   ```

4. Start the ARM RealView Software Wizard:

   ```
   ./setuplinux.bin
   ```

5. Follow the instructions to install ARM Profiler.
3.2 Modifying or uninstalling ARM Profiler

To modify or uninstall ARM Profiler:

1. Make sure that no ARM Profiler component is running before you start.
2. Start the ARM RealView Software Wizard by selecting Applications → ARM → Uninstall Wizard from the menu.
3. Follow the instructions.
4. On the Component choice panel, check the box next to ARM Profiler 2.0 and click Next. Make sure that only the applications that you want to modify are checked.
5. Follow the instructions to complete the required action.

Note

In addition to the ARM → Uninstall Wizard menu option, you can use the ARM → ARM Profiler v2.0.x → Uninstall menu option to uninstall only ARM Profiler.
4 Installing ARM Profiler from the command line

You can install ARM Profiler using a CLI command:

- On Windows:
  `setupcli.exe`
- On Red Hat Linux:
  `/setupclilinux.bin`

4.1 Getting help on the command line installer

You can get help on the command line installer:

- On Windows, enter:
  `setupcli.exe help [command]`
- On Red Hat Linux, enter:
  `/setupclilinux.bin help [command]`

4.2 Installing on Windows

If the installation media is in drive D: and C:\Program Files\ARM is your chosen installation directory, enter the following command:

```
D:\setupcli.exe install --source D: --target "C:\Program Files\ARM" \
--env SYSTEM
```

If you prefer to setup the user environment rather than the system environment, specify --env USER instead. You can also install ARM Profiler to a network share, but each user must then setup their environment to run ARM Profiler as follows:

```
cd [ARM installation directory]\bin\win_32-pentium
armenv --system -p Profiler
```

During installation, the installer asks you to agree to the EULA. Enter yes.

4.3 Installing on Red Hat Linux

If the media is mounted as /mnt/cdrom and /opt/ARM/Profiler is your chosen installation directory, enter the following command:

```
/mnt/cdrom/setupclilinux.bin install --source /mnt/cdrom \
--target "/opt/ARM/Profiler"
```

During installation, the installer asks you to agree to the EULA. Enter yes.

4.4 Installing both variants on a single platform

You can install both the Windows and Red Hat Linux variants of ARM Profiler on a single platform. To do this, use the --var platform argument to specify the non-native platform. Use the following commands to install both variants on your Red Hat Linux platform:

1. Install the Red Hat Linux variant:

   ```
   /mnt/cdrom/setupclilinux.bin install --source /mnt/cdrom \
   --target "/opt/ARM/Profiler"
   ```

2. Install the Windows variant:

   ```
   /mnt/cdrom/setupclilinux.bin install --source /mnt/cdrom \
   --target "/opt/ARM/Profiler" --var platform win_32-pentium --shared
   ```

See Variant syntax on page 7 for details on the syntax of --var.

--shared prevents non-native elements of the installer from running. In this example, elements such as launching the ARM License Wizard and adding items to the Windows Start menu are not performed.
4.5 Uninstalling from the command line

You can uninstall ARM Profiler from the command line:

- On Windows, enter:
  
  ```bash
  setupcli.exe uninstall --product product [--var variant] [--root root] [--shared]
  ```

- On Red Hat Linux, enter:
  
  ```bash
  /setupclilinux.bin uninstall --product product [--var variant] [--root root] [--shared]
  ```

See **Product syntax** for details on the syntax for `product`.
See **Variant syntax** for details on the syntax for `variant`.

--root `root` is the root of your installation. The default is specified by the `ARMROOT` environment variable.
--shared prevents non-native elements of the uninstaller from running. For example, when uninstalling a Windows variant on Red Hat Linux, elements such as removing the ARM License Wizard and removing items from the Windows Start menu are not performed.

4.6 Product syntax

The syntax for specifying the product is:

```
--product category name version revision
```

where:

- **category** The product identifier, for example, Profiler.
- **name** Use the argument Contents.
- **version** The version number of the product, for example, 2.0.
- **revision** A specific build number for the product.

For example, to uninstall ARM Profiler v2.0 on Windows, enter:

```bash
setupcli.exe uninstall --product Profiler Contents 2.0
```

4.7 Variant syntax

The syntax for specifying the variant is:

```
--var name value [name value]...
```

Identifies a variant of the same product.

- **name** The type of the variant, for example, platform. It is suggested that you use only the platform variant.
- **value** The specific variant, such as linux-pentium.

For example, to uninstall the Red Hat Linux variant of ARM Profiler v2.0, enter:

```bash
setupclilinux.bin uninstall --product Profiler 2.0 --var product linux-pentium
```
5 Setting up ARM Profiler for hardware profiling

Once you've installed the ARM Profiler software, you're ready to begin profiling using a Real Time System Model and an ARM executable. If you want to profile using the RealView Trace 2 hardware, you'll need to set up the RealView ICE and RealView Trace 2 units and configure them for use with ARM Profiler.

For a complete guide to the setup and configuration of the RealView ICE/RealView Trace 2 hardware, see the Installation Guide for RealView ICE and RealView Trace 2 and the RealView ICE and RealView Trace 2 User Guides.

___ Note ___

Hardware profiling requires RealView ICE version 3.3 or greater.
6 Getting Started with ARM Profiler using the xvid example

To start your exploration of ARM Profiler using the xvid source code, follow these steps:

--- Note ---
You will need to have RVDS 3.1 or later installed.

---

1. Import the xvid project into Eclipse by choosing File → Import... from the menu.
2. Once the Import dialog has opened, open the General tab, select the Existing Projects into Workspace option and press the Next button to continue.
3. Use the Browse button to navigate to your ARM Profiler install directory (‘Profiler Install Directory’/...\examples\xvid, for example), select the xvid folder and click Finish.
4. Re-build the xvid project by selecting Project → Clean from the menu. After this is complete, select Project → Build Project from the menu. This will build the project and produce a xvid.axf file.
5. Right-click on the newly created xvid.axf file and select Run As → Run on ARM 1136 EB RTSM. Once you click the stop button in the live update window, ARM Profiler will create a xvid_001.apa analysis file that you can open to start exploring ARM Profiler.