3.5.1. Working with source files

The debuggers provide a number of options that enable you to:

The following sections describe these options in detail.

Search paths

To view the source for your program image during the debugging session, you must specify the location of the files. A search path points to a directory or set of directories that are used to locate files whose location is not referenced absolutely.

If you use the ARM command-line tools to build your project, you may need to edit the search paths for your image manually, depending on the options you chose when you built it.

If you move the source files after building an image, use the Search Paths window to change the search paths set up in the ARM Debugger (see Search paths).

To display source file search paths select Search Paths from the View menu. The current search paths are displayed in the Search Paths window.

Follow these steps to add a source file search path:

  1. Select Add a Search Path from the Options menu. The Browse for Folder dialog is displayed.

  2. Browse for the directory you want to add and highlight it.

  3. Click OK.

Follow these steps to delete a source file search path:

  1. Select Search Paths from the View menu. The Search Paths window is displayed.

  2. Select the path to delete.

  3. Press the Delete key.

Listing source files

Follow these steps to examine the source files of the current program:

  1. Display the list of source files by selecting Source Files from the View menu. The Source Files List window is displayed.

  2. Select a source file to examine by double clicking on its name. The file is opened in its own Source File window.

Note

You can have more than one source file open at a time.

Copyright © 1997, 1998 ARM Limited. All rights reserved.ARM DUI 0040D
Non-Confidential