3.5.3. Displaying disassembled and interleaved code

You can display disassembled code in the Execution window or in the Disassembly window. Select Disassembly from the View menu to display the Disassembly window.

You can also choose the type of disassembled code to display by selecting the Disassembly mode submenu from the Options menu. ARM code, Thumb code, or both can be displayed, depending on your image.

To display interleaved C or C++ and assembly language code:

  1. Select Toggle Interleaving from the Options menu to display interleaved source and assembly language in the Execution window. Disassembled code is displayed in grey. The C or C++ code is displayed in black.

Follow these steps to display an area of memory as disassembled code:

  1. Select Disassembly from the View menu, or click

    the Display Disassembly button. The Disassembly Address dialog is displayed.

  2. Enter an address.

  3. Click OK. The Disassembly window displays the assembler instructions derived from the code held in the specified area of memory. Use the scroll bars to display the content of another memory area, or:

    1. Select Goto from the Search menu.

    2. Enter an address.

    3. Click OK.

Specifying a disassembly mode

The ARM debugger tries to display disassembled code as ARM code or Thumb code, as appropriate. Sometimes, however, the type of code required cannot be determined. This can happen, for example, if you have copied the contents of a disk file into memory.

When you display disassembled code in the Execution window you can choose to display ARM code, Thumb code, or both. To specify the type of code displayed, select Disassembly mode from the Options menu.

Copyright © 1997, 1998 ARM Limited. All rights reserved.ARM DUI 0040D
Non-Confidential