2.4.1. Configuring tools

You can change how a tool, such as a compiler or assembler, is executed by changing its configuration within the Project Manager. You can change either the system-wide configuration (see Making system-wide configuration changes), or project-specific configuration (see Making project-specific configuration changes).

Tool configuration can be associated with:

When a tool configuration is associated with a file, it is associated with that file as an input to a build step, not with that file as an output from a build step. For example, if you select an image you can change the debugger configuration but not the linker configuration. Linker configuration is associated with object files.

The Tool Configuration dialog

The appearance of the Tool Configuration dialog varies with the tool you are configuring. Tools that are APM compliant, such as armcc, tcc, armcpp, tcpp, armasm, and armlink, respond by displaying their configuration interface. For most ARM tools this consists of sets of property sheets. Figure 2.9 shows the configuration dialog for the ARM C compiler.

Figure 2.9. Compiler Configuration dialog

Compiler Configuration dialog

When you change the settings, the modifications are reflected in the Equivalent Command Line box near the bottom of the dialog.

Note

If a tool DLL is not in the directories searched by Windows, or if a found tool is not a DLL with APM compliant entry points, an error will be reported because the tool cannot be configured graphically. You can take any of the following actions:

  • install the product containing the missing APM compliant tool DLL (for example C++ projects will need armcpp.dll which is part of C++ 1.10 for SDT 2.50)

  • specify command-line options in the command-line box in the Failed to Locate the Tool dialog

  • select Edit Project Template… Project menu and enter the command-line options in the Command Lines field of the appropriate Build step pattern (see Working with project templates)

  • use the Edit Paths dialog to specify the correct location of the tool DLL (see Editing a path).

Making system-wide configuration changes

System-wide configuration changes to a tool affect all projects that invoke the tool.

Follow these steps to make system-wide configuration changes:

  1. Select Configure from the Tools menu, and select the tool to configure. You are given a warning message about the effects of such a configuration change.

  2. Confirm that you want to proceed. The appropriate Tool Configuration dialog is displayed, showing current settings.

  3. Make any required changes.

  4. Select one of the following:

    • click OK to save the changes and close the dialog

    • click Apply to save the changes and keep the dialog open

    • click Cancel to ignore all changes not applied and close the dialog.

Making project-specific configuration changes

Project-specific configuration can affect an entire project, or specific entities or scope within a project. For example, you can change how a particular source file is compiled, or you can change how all the source for a specific partition is compiled. The Project menu item Tool Configuration for reflects the scope that is affected by the change.

  1. Click on one or more entities, such as the Debug variant in the Project window, to specify the scope of a configuration change. Hold down the Shift or Ctrl keys while clicking to select several entities or a range of entities.

  2. Select Tool Configuration for from the Project menu to display a submenu of the tools used.

  3. Select the tool you want to configure. The Tool Configuration submenu is displayed.

  4. Click Set. The appropriate Tool Configuration dialog is displayed, showing current settings and allowing you to make changes.

  5. Make any required changes.

  6. Select one of the following:

    • click OK to save the changes and close the dialog

    • click Apply to save the changes and keep the dialog open

    • click Cancel to ignore all changes not applied and close the dialog.

Resetting tool configuration

You can return the configuration of a tool to the settings of its parent (see Project hierarchy) as follows:

  1. Click on one or more entities, for example the Debug variant, in the Project window to select the scope for the configuration change.

  2. Select Tool Configuration for from the Project menu, then select the tool to be configured. The Tool Configuration submenu is displayed. If there is a configuration setting for the selected scope, the Unset menu item is enabled.

  3. Select Unset to reset the configuration to the settings of that tool at the next higher level of hierarchy.

Reading compiler options from a file

There are two options that allow you to read additional command-line options from a file. These options must be specified on the Extra command line arguments text box of the Configuration Dialog:

-via filename

Opens a file and reads additional command-line options from it. For example:


armcpp -via input.txt options source.c

The options specified in filename are read at the same time as any other command-line options are parsed. If -via is specified in the Extra command line arguments text box of the APM Compiler Configuration dialog, the command-line options are immediately read into the tool configuration settings.

You can nest -via calls within -via files.

-latevia filename

This option is similar to -via. In the case of -latevia the file is read immediately before compilation begins, not when other command-line options are parsed.

If -latevia is specified, the command-line options are not read in until the compiler is executed. This means that files specified with the -latevia option stay in the text box, and can be changed more easily than files specified with the -via option.

Calls to -latevia files cannot be nested. If -latevia is specified within a -latevia file, it is ignored. However, you can nest -via options within -latevia files.

Copyright © 1997, 1998 ARM Limited. All rights reserved.ARM DUI 0040D
Non-Confidential