3.2.2. Starting and closing the debugger

Start and close the ADW or ADU as follows.

Starting the ARM Debugger

Start the ARM Debugger for Windows (ADW) in any of the following ways:

  • if you are running Windows 95 or Windows 98, click on the ARM Debugger for Windows icon in the ARM SDT v2.50 Program folder

  • if you are running Windows NT4, double click on the ARM Debugger for Windows icon in the ARM SDT v2.50 Program group or select Start  ? Programs  ? ARM SDT v2.50  ? ARM Debugger for Windows

  • if you are working in the ARM Program Manager, click the ARM Debugger button or select Debug project from the Project menu

  • launch ADW from the DOS command-line, optionally with arguments.

Start the ARM Debugger for UNIX (ADU) in either of the following ways:

  • from any directory type the full path and name of the debugger, for example, /opt/arm/adu

  • change to the directory containing the debugger and type its name, for example, ./adu

The possible arguments (which must be in lower case) for both ADW and ADU are:

-debug ImageName

Load ImageName for debugging.

-exec ImageName

Load and run ImageName.

-reset

Reset the registry settings to defaults.

-nologo

Do not display the splash screen on startup.

-nowarn

Do not display the warning when starting remote debugging.

-nomainbreak

Do not set a breakpoint on main() on loading image.

-script ScriptName

Obey the ScriptName on startup. This is the equivalent of typing obey ScriptName as soon as the debugger starts up.

-symbols

Load only the symbols of the specified image. This is equivalent to selecting Load Symbols only… from the File menu.

-li, -bi

Start the debugger in LIttle-endian or BIg-endian mode.

-armul

Start the debugger using the ARMulator.

-adp -linespeed baudrate [-port [s=serial port[,p=parallel port]] |[e=ethernet address]]

Start the debugger using Remote_A, if available in the current RDI connection list.

You can use -linespeed baudrate only in conjunction with -adp, to specify the baud rate of the connection.

You can use -port only in conjunction with -adp, to specify the connection to the device.

For example, to launch ADW from the command-line and load sorts.axf for debugging, but without setting a breakpoint on main(), type:

adw -debug sorts.axf -nomainbreak 

To launch ADW (with arguments) from APM, select Project  ? Edit Variables  ? adw and enter the arguments after adw in the Value box. Refer to Specifying command-line arguments for your program for more information on specifying command-line options.

When you start the ARM Debugger, the windows you were using last time are again displayed. These usually include the Console, Command, and Execution windows, and you can load your executable image.

Closing the ARM Debugger

Select Exit from the File menu to close down the ARM Debugger.

Copyright © 1997, 1998 ARM Limited. All rights reserved.ARM DUI 0040D
Non-Confidential