2.2.5. Project output

The output of a project is typically a single file or a closely related group of files, such as a program image or an object library.

The output is determined by one or more of the build step patterns in the project template. A different version of the project output is created for each variant built. For example, output can be built for a debug-and-release version, a debug version, and a release version.

Using the project output

When your project has been successfully built, you can either execute or debug it to see how it works. Use the ARM Debugger for Windows (see ARM Debuggers for Windows and UNIX on page 3-1 for more information).

Executing an image

Click the Execute button or select Execute project.apj from the Project menu, to load the image in to the ARM Debugger for Windows and commence execution. If you execute the hello.apj project, ‘Hello World’ appears in the Console Window.

Select Exit from the File menu when you have finished executing the image.

Debugging an image

When you click the Debug button or select Debug project.apj from the Project menu, again the image is loaded into the ARM Debugger for Windows, but the debugger is halted at the start of the program. You can then debug the image as necessary, using the features of the Debugger.

Note

Whether you Execute or Debug your image, if the project output is older than its source, it is rebuilt before it is sent to the Debugger.

Copyright © 1997, 1998 ARM Limited. All rights reserved.ARM DUI 0040D
Non-Confidential