RealView ® Debugger EssentialsGuide

Version 1.8


Table of Contents

Preface
About this book
Intended audience
Examples
Using this book
Typographical conventions
Further reading
Feedback
Feedback on RealView Debugger
Feedback on this book
1. Using the Essentials Guide
1.1. Using this book
1.2. Using the documentation suite
2. About RealView Debugger
2.1. RealView Debugger
2.1.1. RealView Debugger concepts and terminology
2.2. About the debugging environment
2.2.1. Components of RealView Debugger
2.2.2. Debug target interface
2.2.3. Persistence information
2.3. Debugging mode
3. Changes to RealView Debugger
3.1. RealView Debugger v1.8 SP1 overview
3.2. Getting more information online
4. RealView Debugger Desktop
4.1. Basic elements of the desktop
4.1.1. Splash screen
4.1.2. Code window
4.1.3. Default pane configuration
4.1.4. Debug views and panes
4.1.5. Pane controls
4.1.6. Button toolbars
4.1.7. Color Box
4.1.8. Other window elements
4.2. Finding options on the main menu
4.3. Working with the Code window toolbars
4.3.1. File toolbar
4.3.2. Edit toolbar
4.3.3. Debug toolbar
4.3.4. Image toolbar
4.3.5. Connect toolbar
4.3.6. Build toolbar
4.3.7. Find toolbar
4.3.8. Customizing the toolbars
4.4. Working in the Code window
4.4.1. Floating, docking, and resizing windowsand panes
4.4.2. Changing the focus
4.4.3. In-place editing
4.4.4. Working with tabs
4.4.5. Working with scroll bars
5. Getting Started with RealView Debugger
5.1. How to use the tutorial
5.2. Starting the tutorial
5.3. Starting RealView Debugger
5.4. Localizing the RealView Debugger interface
5.4.1. Font recommendations
5.4.2. Procedure summary
5.4.3. Configuring the internationalizationsettings
5.4.4. Configuring the pane views
5.5. Connecting to a debug target
5.5.1. How to display the Connection Controlwindow
5.5.2. Elements of the ConnectionControl window
5.5.3. Making a connection
5.5.4. Configuring your debug target
5.5.5. Setting connect mode
5.6. Working with memory
5.6.1. Using the default setting for topof memory and stack values
5.6.2. Setting top of memory for a session
5.7. Loading an image ready for debugging
5.7.1. Loading an image directly
5.7.2. Loading an image associated with a RealView Debugger project
5.7.3. Loading multi-imageapplications to a single debug target
5.7.4. Reloading an image
5.8. Viewing debugger resources
5.8.1. How to display the Resource Viewer window
5.8.2. Elements of the Resource Viewer window
5.8.3. File menu
5.8.4. View menu
5.8.5. RSD menu
5.8.6. Help menu
5.8.7. Resources toolbar
5.8.8. Resources list
5.8.9. Details area
5.9. Running the image
5.10. Basic debugging tasks with RealView Debugger
5.10.1. Getting started
5.10.2. Displaying line numbers
5.10.3. Using the code views
5.10.4. Viewing target status
5.10.5. Using breakpoints in RealView Debugger
5.10.6. Viewing your hardware breakpoint support
5.10.7. Setting default breakpoints
5.10.8. Setting conditional breakpoints
5.10.9. Managing breakpoints
5.10.10. Setting watches
5.10.11. Displaying register contents
5.10.12. Changing register contents
5.10.13. Process control
5.10.14. Displaying memory contents
5.10.15. Displaying variables
5.10.16. Tooltip evaluation
5.10.17. Using the call stack
5.10.18. Using the stack
5.10.19. Using the Data Navigator pane
5.10.20. Using the Symbol Browser pane
5.11. Unloading an image
5.11.1. How to explicitly unload an image
5.12. Saving the session
5.12.1. Workspace
5.12.2. Startup file
5.12.3. History file
5.12.4. Settings options
5.13. Disconnecting from a target
5.13.1. Setting disconnect mode
5.14. Exiting RealView Debugger
5.14.1. Closing down without a connection
5.14.2. Closing down with a connection
5.14.3. Reconnecting to a target
5.15. Completing the tutorial
5.15.1. Removing tutorial project files
5.15.2. Removing the tutorial project
6. Getting Started with RealView Debugger Projects
6.1. Help on creating RealView Debugger projects
6.1.1. Types of project
6.1.2. Project properties
6.1.3. Limitations of Standard and Libraryprojects
6.1.4. Making a project and a connectioninterdependent
6.1.5. Automatic operations performed bya project
6.2. Setting up project build options forthe basic compilation tasks
6.2.1. References to project settings
6.2.2. Targeting the sourcelanguage
6.2.3. Targeting the ARM orThumb instruction set
6.2.4. Targeting a specific ARM architectureor processor
6.2.5. Targeting specific procedure callstandard variants
6.2.6. Generating debug information
6.2.7. Optimizing your compiled sources
6.2.8. Building an image with a single compilerinvocation
6.2.9. Building an image with separate commandinvocations
6.2.10. Specifying the initial entry pointfor an image
6.2.11. Creating object libraries
6.2.12. Converting images to binary files
6.2.13. Creating an image memory map withscatter-loading
6.2.14. Project settings for the example Dhrystoneproject
7. Getting Started with the RealView Debugger Command Line Interface
7.1. About the CLI
7.1.1. The CLI interfaces of RealView Debugger
7.1.2. Why use the CLI?
7.1.3. Accessing the CLI from the GUI
7.1.4. Getting help
7.2. Entering commands interactively inthe GUI
7.3. Entering batched commands
7.3.1. Using the -inc command-line option
7.3.2. Using the INCLUDE command
7.3.3. Using the Command setting in the boardfile advanced information block
7.3.4. Adding comments to your batch files
7.3.5. Using the QUIT command in batch files
7.4. Using the headless debugger
7.4.1. Starting the headless debugger
7.4.2. Connecting to a debug target
7.4.3. Disconnecting the current connection
7.4.4. Loading an image
7.4.5. Loading a Flash image
7.4.6. Displaying the current working directory
7.4.7. Capturing commands and output
7.4.8. Working with multiple connections
A. Configuration Files Reference
A.1. Overview
A.2. Files in the etc directory
A.3. Files in the home directory
A.3.1. Backup files
B. Moving from AXD to RealView Debugger
B.1. RealView Debugger configuration
B.1.1. Where do I find Debugger Internalvariables?
B.1.2. How do I set top_of_memory?
B.1.3. How do I configure vector_catch?
B.1.4. How do I configure semihosting?
B.2. RealView Debugger operations
B.2.1. Why am I unable to connect to more than one target?
B.2.2. Viewing Coprocessor variables
B.2.3. How do I load symbols for an image?
B.2.4. RealView ARMulator ISS Benchmarking
B.2.5. Debug illusion issues
B.3. Project management in RealView Debugger
B.3.1. Can I convert CodeWarrior projects into RealView Debugger projects?
B.3.2. Specifying paths to header files in projects
B.3.3. Adding source files to an existing project
B.3.4. How does RealView Debugger make use of makefiles?
B.3.5. Can I use existing makefiles with RealView Debugger?
B.4. Comparison of RealView Debugger and AXD commands
B.5. Converting legacy AXD scripts to RealView Debugger format
B.5.1. axd2rvd command syntax
C. Moving from armsd to RealView Debugger
C.1. Comparison of RealView Debugger and armsdcommands
C.2. Converting legacy armsd scripts to RealView Debugger format
C.2.1. armsd2rvd command syntax
D. Mapping of Menu Options to Toolbar Buttons
D.1. Main menu to toolbar button mapping
E. About Previous Releases
E.1. Changes between RealView Debugger v1.8 andv1.7
E.1.1. Updated documentation
E.1.2. Trace, Analysis, and Profiling
E.1.3. Support for gcc built images
E.1.4. Changes to the GUI
E.1.5. Changes to the CLI
E.1.6. RealView ARMulator ISS support
E.1.7. RealMonitor support
E.2. Changes between RealView Debugger v1.7 andv1.6.1
E.2.1. Updated documentation
E.2.2. Advanced debugging facilities
E.2.3. RealView ARMulator ISS
E.2.4. Trace, Analysis, and Profiling
E.2.5. Enhanced RTOS support
E.2.6. New GUI elements
E.3. Changes between RealView Debugger v1.6.1and v1.6
E.3.1. Updated documentation
E.3.2. Advanced debugging facilities
E.3.3. Trace, Analysis, and Profiling
E.3.4. RealView Debugger downloads
E.4. RealView Debugger v1.6
E.4.1. Multi-core debugging
E.4.2. OS awareness
E.4.3. Extended Target Visibility (ETV)
E.4.4. Advanced debugging facilities
E.4.5. Trace, Analysis, and Profiling
E.4.6. Project manager
E.4.7. RealView Debugger downloads
Glossary

ProprietaryNotice

Words and logos marked with ® or ™ are registered trademarks or trademarksowned by ARM Limited. Other brands and names mentioned herein maybe the trademarks of their respective owners.

Neither the whole nor any part of the information containedin, or the product described in, this document may be adapted orreproduced in any material form except with the prior written permissionof the copyright holder.

The product described in this document is subject to continuousdevelopments and improvements. All particulars of the product andits use contained in this document are given by ARM in good faith.However, all warranties implied or expressed, including but notlimited to implied warranties of merchantability, or fitness forpurpose, are excluded.

This document is intended only to assist the reader in theuse of the product. ARM Limited shall not be liable for any lossor damage arising from the use of any information in this document,or any error or omission in such information, or any incorrect useof the product.

ConfidentialityStatus

This document is Non-Confidential. The right to use, copyand disclose this document may be subject to license restrictionsin accordance with the terms of the agreement entered into by ARMand the party that ARM delivered this document to.

Product Status

The information in this document is final, that is for a developedproduct.

Revision History
Revision A April2002 RealView Debugger v1.5 release
Revision B September2002 RealView Debugger v1.6 release
Revision C February2003 RealView Debugger v1.6.1 release
Revision D September2003 RealView Debugger v1.6.1 release for RVDSv2.0
Revision E January2004 RealView Debugger v1.7 release for RVDS v2.1
Revision F December2004 RealView Debugger v1.8 release for RVDS v2.2
Revision G May2005 RealView Debugger v1.8 SP1 release for RVDSv2.2 SP1
Copyright © 2002-2005 ARM Limited. All rights reserved. ARM DUI 0181G
Non-Confidential