A.2.4. Changes to the GUI

This section describes the major changes to the RealView Debugger GUI.

Changes to the Code window main menu structure

The Code window main menus have been restructured, with new menus added, and menu options moved to reflect their functionality:

File

The following changes have been made to this menu:

  • the image load options are now available on the new Target menu

  • connections are now available on the new Target menu

  • logs and journals are now available on the Tools menu

  • all workspace-related options are now available from the Workspace submenu.

Note

The Threads menu option has been removed, because this feature is available using the Cycle Threads toolbar button.

Edit

All editing-related functionality is now available from this menu, including copying and pasting, and searching. The changes include the following:

  • the new Advanced submenu contains the options from the old Format and Editing Controls submenus

  • the new Go To submenu contains the original Jump options.

  • removal of some little-used options, such as VI mode.

View

All pane views are now accessible from the main View menu, instead of the New Pane Views submenu. A new Data Navigator option is available to display the Data Navigator pane. The Browse Symbols dialog box is replaced by a Symbol Browser pane, which has enhanced functionality.

Target

This is a new menu that includes all options relating to connections and image loading.

Project

This menu contains all the project-related options available in previous versions of RealView Debugger, but the grouping has changed.

Build

This is a new menu that includes all the build-related options from the Tools menu.

Debug

The following changes have been made to this menu:

  • the options on the Execution Control are now available on the main Debug menu.

  • the breakpoint options are combined into a single Breakpoints... submenu

  • the Debug/Simple Breakpoints submenu options are redistributed between the new Breakpoints submenu and the new Breakpoints ? Conditional submenu

  • the Complex Breakpoints submenus options are now available from the Breakpoints ? Hardware... submenu

  • the Processor Events option is now available from the option Processor Exceptions...

  • the Include Commands from File... option is now available on the Tools menu.

Tools

The following changes have been made to this menu:

  • the build-related options are now available on the new Build menu

  • the workspace options are now available from the File ? Workspace menu

  • a new Logs and Journal submenu is available for opening and closing log and journal files

  • the Include Commands from File... option has been moved to this menu from the Debug menu

  • the New Editor submenu has been removed.

Help

The following changes have been made to this menu:

  • all web-related options are now on the ARM on the Web submenu

  • the Full Online Documentation option has been removed

  • access to the RealView Debugger online help is simplified, and is now available through the RealView Debugger Help option.

Toolbar changes

The Code window toolbar is now split into separate function-specific toolbars. Each toolbar can be hidden, moved, or floated independently. The toolbars are:

  • File

  • Edit

  • Debug

  • Image

  • Connect

  • Build

  • Find.

Internationalization is now supported

Internationalization is now supported, so that you can localize the RealView Debugger interface. You can:

  • set the language to English (the default), or Japanese

  • set the default encoding to ASCII (the default), UTF-8, or Locale.

This displays the main menu and various context menu options in the chosen language. For instructions on how to change the these settings, see the RealView Debugger User Guide.

Changes to pane views

The following changes have been made to panes in RealView Debugger:

  • You now have greater flexibility over the docking of panes.

  • All panes, except for the File Editor pane, can be floated, hidden, and repositioned on the RealView Debugger desktop.

  • You can now set the font used in the pane views. You can set the font name, style, size, and script.

  • There is a new Data Navigator pane that enables you to quickly locate a module, function, or variable in an image.

  • The Browse Symbols dialog box is replaced by a Symbol Browser pane, which has enhanced functionality.

  • The Expand/Collapse Pane button has been removed from the pane toolbar.

Changes to breakpoints

Breakpoints are no longer categorized as Simple and Complex. They are now categorized as Software and Hardware, and as unconditional or conditional. As a consequence, the names of the various dialog boxes used to set breakpoints have changed. See the RealView Debugger User Guide for more details.

The Set Address/Data Break/Tracepoint dialog box can now only be used to set breakpoints. Therefore, this dialog box is now called Set Address/Data Breakpoint.

Named breakpoints are no longer supported. Although the Named_breaks group is still present in the Project Properties, the Named... menu option has been removed. The Named_breaks group is to be removed in a future release.

Changes to tracepoints

The following changes have been made to tracepoints:

  • Tracepoints are no longer categorized as Simple and Complex. They are now categorized as unconditional or conditional.

  • You can no longer use the Set Address/Data Break/Tracepoint dialog box to set tracepoints. Therefore, this dialog box is now called Set Address/Data Breakpoint.

See the chapter that describes tracing in RealView Debugger in the RealView Debugger Extensions User Guide for more details.

Changes to editing facilities

The following changes have been made to the editing facilities in RealView Debugger:

  • You now have more control over source code coloring. You can:

    • set both the foreground text color and the background color for various code elements

    • choose the default colors from a list of color schemes, such as Visual Studio

    • set colors for the additional code element identifiers, preprocessor keywords, and operators.

  • You can now set the font used in the pane views. You can set the font name, style, size, and script.

  • The standalone Editor window has been removed. Also, there is no longer support for using personal standalone editors with RealView Debugger.

  • You can no longer use Vi mode when editing.

Copyright © 2002-2007 ARM Limited. All rights reserved.ARM DUI 0181I
Non-Confidential