11.2.3. Workspace Options window

The Workspace Options window enables you to examine your current workspace settings and edit these settings to change the workspace or to create your own workspace files. The first time RealView Debugger opens the default workspace file, rvdebug.aws, the Workspace Options window contains only the start-up settings, shown in Figure 11.2.

Figure 11.2. Workspace Options window

Workspace Options window

The main interface components of this window are:

Main menu

This contains:

File

Displays the File menu where you can save the workspace file after you have made changes.

View

Displays the View menu to toggle the display to show all the settings or only those that have been edited.

Help

Displays the online Help menu.

Save icon

Click this icon to save the workspace settings file to disk. The name of the current file is shown as the first entry in the left pane.

Description

This field displays a one-line description about an entry selected in the panes below.

List of Entries and Settings Values

The left pane of the Workspace Options window, the List of Entries pane, shows workspace entries as a hierarchical tree with node controls. Groups of settings are associated with an icon to explain their function:

Red disk

This is a container disk file, for example to specify an include file.

Yellow folder

This is a parent group containing other groups (rules pages) and/or entries.

Rules page

A rules page is a container for settings values that you can change in the right pane. This icon only appears in the left pane.

When you close down RealView Debugger, your workspace settings file is updated with the current configuration, for example projects, the connection, and open windows. An asterisk (*) is placed at the front of an entry to show that it has changed from the default or was created by RealView Debugger. An example settings file is shown in Figure 11.3.

Figure 11.3. Example Workspace Options

Example Workspace Options

If you click on an entry in the left pane, a red box is drawn around it and the Description field is updated. At the same time, the right pane, the Settings Values pane, is updated to show the contents of the highlighted group.

Note

See the RealView Debugger online help topic Changing Settings for details on all the entries in the Workspace Options window.

Copyright © 2003, 2004 ARM Limited. All rights reserved.ARM DUI 0234B
Non-Confidential