RealView ® Developer Kit Debugger UserGuide

Version 1.0


Table of Contents

Preface
About this book
Intended audience
Before you start
Examples
Using this book
Typographical conventions
Further reading
Feedback
Feedback on the RealView Developer Kit
Feedback on this book
1. Starting to use RealView Debugger
1.1. Starting RealView Debugger
1.1.1. Starting from Windows
1.1.2. Starting from the command line
1.1.3. Setting environment variables
1.2. RealView Debugger directories
1.2.1. Defining the installation directory
1.2.2. Defining the home directory
1.2.3. Using the examples directories
2. Connecting to Targets
2.1. The Connection Control window
2.1.1. Using the Connection Control window
2.1.2. Groups in the Connection Control window
2.2. Managing connections
2.2.1. The vehicle menu
2.2.2. The target menu
2.3. Connecting to a target
2.3.1. Using the Connection Control window
2.3.2. Including the connection in the workspace
2.3.3. Using CLI commands
2.3.4. Setting connect mode
2.4. Failing to make a connection
2.4.1. Troubleshooting
2.5. Disconnecting from a target
2.5.1. Using the File menu to disconnect
2.5.2. Using the Connection Control window todisconnect
2.5.3. Using the CLI
2.5.4. Disconnecting by exiting
2.5.5. Setting disconnect mode
3. Working with Images
3.1. Loading images
3.1.1. Loading from a user-defined project
3.1.2. Using the Load File to Target dialogbox
3.1.3. Loading from the Process Control pane
3.1.4. Quick loading
3.1.5. Loading from the command line
3.1.6. Loading and runtime visualization
3.2. Managing images
3.2.1. Viewing image details in the Codewindow
3.2.2. Viewing image details in the ProcessControl pane
3.2.3. Working with auto-projects
3.2.4. Working with user-defined projects
3.3. Working with symbols
3.4. Working with multiple images
3.5. Unloading and reloading images
3.5.1. Resetting your target processor
3.5.2. Unloading an image
3.5.3. Reloading an image
4. Controlling Execution
4.1. Submitting commands
4.2. Defining execution context
4.2.1. Code views
4.2.2. Defining scope and context
4.3. Using Execution controls
4.3.1. Using the Execution group
4.3.2. Using shortcuts
4.4. Working with the Debug menu
4.4.1. Using the Debug menu
4.4.2. Using the Execution Control menu
4.5. Controlling debugging
4.5.1. Using include files
4.5.2. Searching for source files
5. Working with Breakpoints
5.1. Breakpoints in RealView Debugger
5.1.1. Breakpoint types
5.1.2. Using hardware breakpoints
5.2. Setting breakpoints quickly
5.2.1. Quick breakpoints in source-levelview
5.2.2. Quick breakpoints in disassembly-levelview
5.2.3. Viewing breakpoints in your code view
5.2.4. Clearing breakpoints quickly
5.2.5. Setting breakpoints in other ways
5.3. Using simple breakpoints
5.3.1. Using the Set Address/Data Break/Tracepointdialog box
5.3.2. Setting simple conditional breakpoints
5.3.3. Breakpoint operations
5.3.4. Setting breakpoints from saved lists
5.4. Setting conditional breakpoints
5.4.1. Managing qualifiers and actions
5.4.2. Attaching macros to breakpoints
5.5. Setting hardware breakpoints
5.5.1. Setting simple hardware breakpoints
5.5.2. Using ranges and masks
5.6. Using complex breakpoints
5.6.1. Setting complex breakpoints
5.7. Using the Break/Tracepoints pane
5.7.1. Displaying the Break/Tracepoints pane
5.7.2. Viewing breakpoints in the Break/Tracepointspane
5.7.3. Using the Break/Tracepoints menu
5.7.4. Working in the Break/Tracepoints pane
5.7.5. Using the Pane menu
5.8. Disabling and clearing breakpoints
5.8.1. Disabling breakpoints
5.8.2. Clearing breakpoints
5.8.3. Clearing all breakpoints
5.9. Saving breakpoints as favorites
5.9.1. Creating a breakpoint favorite
5.9.2. Saving existing breakpoints as favorites
6. Memory Mapping
6.1. About memory mapping
6.2. Enabling and disabling memory mapping
6.3. Setting up a memory map
6.4. Viewing the memory map
6.4.1. Working with the Map tab
6.4.2. Memory map configuration
6.4.3. Using the Map tab context menu
6.5. Editing map entries
6.5.1. Updating map entries based on registers
6.6. Setting top of memory and stack values
6.7. Generating linker command files
7. Monitoring Execution
7.1. Working with registers
7.1.1. Displaying register contents
7.1.2. Formatting options
7.1.3. Changing register contents
7.1.4. Semihosting
7.1.5. Viewing internal variables
7.1.6. Defining new registers
7.1.7. Interactive operations
7.2. Working with memory
7.2.1. Displaying memory contents
7.2.2. Formatting options
7.2.3. Operating on memory contents
7.2.4. Changing memory contents
7.2.5. Interactive operations
7.3. Working with the stack
7.3.1. Using the Stack pane
7.3.2. Formatting options
7.3.3. Operating on stack contents
7.3.4. Context controls
7.3.5. Setting a breakpoint
7.3.6. Interactive operations
7.4. Using the call stack
7.4.1. Using the Stack pane
7.4.2. Using the Call Stack pane
7.4.3. Using context menus
7.4.4. Stack controls
7.5. Working with watches
7.5.1. Setting watches in source-level view
7.5.2. Working with the Watch pane
7.5.3. Managing watches
7.5.4. Saving watches as favorites
8. Reading and Writing Memory, Registers, and Flash
8.1. About interactive operations
8.2. Using the Memory/Register Operationsmenu
8.3. Accessing interactive operations inother ways
8.3.1. From the Memory pane
8.3.2. From the Stack pane
8.3.3. From the Dsm tab
8.4. Working with Flash
8.4.1. Flash definition files
8.4.2. Flash Method files
8.4.3. Flash examples
8.4.4. Flash programming
8.4.5. Using the Flash Memory Control
8.5. Examples of interactive operations
8.5.1. Setting memory
8.5.2. Setting registers
8.5.3. Downloading memory to a file
8.5.4. Comparing memory with file contents
8.5.5. Filling memory with a pattern
8.5.6. Setting Flash memory
9. Working with Browsers
9.1. Using browsers
9.1.1. Accessing list browsers
9.2. Browsing modules and files
9.2.1. Specifying the list
9.2.2. Scoping to a module or file
9.2.3. Closing the browser
9.3. Browsing functions
9.3.1. Specifying the list
9.3.2. Refining the list
9.3.3. Viewing details of a function
9.3.4. Scoping to a function
9.3.5. Setting a breakpoint
9.3.6. Closing the browser
9.4. Browsing variables
9.4.1. Specifying the list
9.4.2. Refining the list
9.4.3. Viewing details of a variable
9.4.4. Closing the browser
9.5. Specifying browser lists
9.5.1. Specifying a list
9.5.2. Applying a filter
9.6. Browsing C++ classes
9.6.1. Viewing details of a class
9.6.2. Viewing details of a function
9.7. Other routes to the browsers
10. Working with Macros
10.1. About macros
10.1.1. Properties of macros
10.1.2. RealView Debugger commands in macros
10.1.3. Defining macros
10.1.4. Calling macros
10.1.5. Macro return values
10.1.6. Using macros with breakpoints
10.1.7. Attaching macros
10.1.8. Stopping macros
10.2. Using macros
10.2.1. Creating a macro
10.2.2. Viewing a macro
10.2.3. Testing a macro
10.2.4. Editing a macro
10.2.5. Copying a macro
10.2.6. Deleting a macro
10.2.7. Calling a macro
10.3. Source patching with macros
10.3.1. Patching example to reset Program Counter
10.3.2. Patching example to emulate a serialport
10.3.3. Other ways to use macros
10.4. Macro language
10.4.1. Macro definition
10.4.2. Macro body
10.4.3. Macro terminator
10.4.4. Macro comments
10.4.5. Macro local symbols
10.4.6. Macro conditional statements
10.5. Predefined macros
11. Configuring Workspace Settings
11.1. Using workspaces
11.1.1. Initializing the workspace
11.1.2. Workspace menu
11.1.3. Settings options
11.1.4. Opening workspaces
11.1.5. Closing workspaces
11.1.6. Projects in workspaces
11.1.7. Creating an empty workspace
11.2. Viewing workspace settings
11.2.1. Using Settings windows
11.2.2. Options window
11.2.3. Workspace Options window
11.2.4. Groups and settings
11.3. Configuring workspace settings
11.3.1. Changing settings
11.3.2. Copying entries
11.3.3. Pasting entries
11.3.4. Cutting entries
11.3.5. Resetting entries
12. Managing Projects
12.1. About managing projects
12.1.1. What is a project?
12.1.2. User-defined projects
12.1.3. Auto-projects
12.1.4. Organizing user-defined projects
12.1.5. Build tools for user-defined projects
12.1.6. Project properties
12.1.7. Build target configurations
12.1.8. Makefiles
12.1.9. Project binding
12.1.10. Projects in the workspace
12.1.11. Projects in Connection Properties
12.2. Using the Project and Tools menus
12.2.1. Active project
12.2.2. Using the Project menu
12.2.3. Using the Tools menu
12.3. Managing your build tools
12.3.1. Build-Tool Properties
12.3.2. Defining build tools
12.4. Managing user-defined projects
12.4.1. Opening a user-defined project
12.4.2. Generated makefiles
12.4.3. Project properties
12.4.4. Adding files to a user-defined project
12.4.5. Closing a user-defined project
12.5. Creating a new user-defined project
12.5.1. Before you start
12.5.2. Common steps for creating a user-definedproject
12.5.3. Steps for creating a Standard or Libraryproject
12.5.4. Steps for creating a Custom project
12.5.5. Steps for creating a Container project
12.5.6. Steps for copying an existing user-definedproject
12.5.7. Customizing and building your project
12.5.8. Merging auto-project settings intoa project
12.6. Building your application
12.6.1. Using a build model
12.6.2. Resetting line numbers
12.6.3. Building files and images
12.6.4. Using the Build dialog box
12.6.5. Finding build errors
12.7. Managing project properties
12.7.1. Viewing project properties
12.7.2. Project Properties window
12.7.3. Groups available for each type ofproject
12.7.4. Disabling a group
12.7.5. Viewing the Configuration Summary
12.8. Configuring project properties
12.8.1. Customizing your project
12.8.2. Adding source files to a project
12.8.3. Removing source files from a project
12.8.4. Compiling a specificsource file
12.8.5. Excluding source files from a build
12.8.6. Changing the location of object files
12.8.7. Changing build tools for a specificuser-defined project
12.8.8. Managing build target configurations
12.8.9. Using MS-DOS names under Windows
12.8.10. Using MS-DOS applications
12.8.11. Customizing the build
12.8.12. Adding object files
12.8.13. Adding library files
12.8.14. Specifying paths to include files
12.8.15. Adding prelink and postlink commands
12.8.16. Specifying breakpoints
12.8.17. Specifying linker options and scatterloading
12.8.18. Interworking ARM and Thumb
12.9. Managing build target configurations
12.9.1. About build target configurations
12.9.2. Creating a build target configuration
12.9.3. Deleting a build target configuration
12.9.4. Changing the active build target configuration
12.9.5. Changing the order of build targetconfigurations
12.9.6. Assigning a specificsetting to a build target configuration
12.9.7. Removing a setting from a build targetconfiguration
12.9.8. Assigning multiple settings to a specificbuild target configuration
12.10. Using the Project Control dialog box
12.10.1. Viewing the Project Control dialogbox
12.10.2. Working with the Project Control dialogbox
12.11. Managing projects in the Process Controlpane
12.11.1. Displaying the Process Control pane
12.11.2. Working with user-defined projects
12.11.3. Working with auto-projects
12.11.4. Project contextmenus
12.12. Project binding
12.12.1. Types of binding
12.12.2. Viewing project binding
12.12.3. Forcing binding
12.12.4. Effects of binding
12.12.5. Effects of unbinding
12.12.6. Connecting and disconnecting
12.13. Managing multiple projects
12.13.1. Working with multiple projects
12.13.2. Active projects
12.13.3. Working with Container projects
12.13.4. Working with auto-projects
12.13.5. Closing projects
12.13.6. Connecting and disconnecting
13. Editing Source Code
13.1. About the File Editor
13.1.1. Using the File Editor pane
13.1.2. Using standalone editors
13.1.3. Using personal editors
13.1.4. Editing binary files
13.2. Configuring the File Editor
13.2.1. Changing your Editing Controls
13.2.2. Working with multiple files
13.3. Using the Editor Buffer List
13.3.1. Displaying files in the Editor Buffer List
13.4. Editing text
13.4.1. Basic text editing
13.4.2. Formatting text
13.4.3. Undoing changes
13.4.4. Using drag-and-drop
13.5. Managing your editing session
13.5.1. Using the Find menu
13.5.2. Using Editing Controls
13.5.3. Setting source search paths
13.5.4. Changing your workspace settings
13.6. Using standalone editors
13.6.1. Using a personal editor
13.7. Using templates
13.7.1. Inserting templates
13.7.2. Creating templates
13.7.3. Template examples
13.8. Working in vi mode
13.8.1. Using ex editor commands
14. Searching and Replacing Text
14.1. About finding and replacing text
14.2. Searching and replacing text
14.2.1. Searching for text
14.2.2. Searching and replacing text
14.2.3. Searching for selected text
14.3. Searching multiple files
14.3.1. Viewing search results
14.4. Working with functions
14.4.1. Jumping to a function
14.4.2. Jumping to a function definition
14.4.3. Returning from a jump
14.5. Pair matching
14.5.1. Searching pairs
14.5.2. Matching pairs
14.5.3. Matching nested pairs
14.5.4. Enclosing
14.6. Configuring searches
14.6.1. Using the Find dialog box
14.6.2. Changing your workspace settings
14.7. Using regular expressions
14.7.1. About special operators
14.7.2. Searching with regular expressions
15. Working with Version Control Systems
15.1. Defining the version control tool
15.2. Using a version control tool
15.2.1. Changing the status of controlledfiles
15.2.2. Using source control commands
15.2.3. Setting up a prompt
15.3. Configuring a custom version control tool
15.3.1. Changing your workspace settings
15.3.2. Specifying custom commands
16. Connection and Target Configuration
16.1. About RealView Debugger target configuration
16.2. Comparing target configuration toconnection configuration
16.2.1. Connection entries
16.2.2. Configuration entries
16.3. Configuration files
16.3.1. What the configuration files contain
16.3.2. Saving and restoring connection properties
17. Configuring Custom Targets
17.1. About target configuration
17.1.1. Target configuration
17.1.2. Configuration files
17.1.3. Default configuration files
17.1.4. Using other board files
17.2. The supplied target descriptions
17.3. Creating new target descriptions
17.3.1. Saving and restoring your .brd file
17.3.2. Creating a *.bcd file
17.3.3. Creating and naming a board, chip,or component
17.3.4. Linking a board, chip, or componentto a connection
17.4. Example descriptions
17.4.1. Viewing the new target definition
17.4.2. Configuring a memory map
17.4.3. Setting up a custom register
17.4.4. Setting up memory blocks
17.4.5. Setting top of memory and stack heapvalues
17.4.6. Flash programming
17.4.7. Restoring your .brd file
17.4.8. Troubleshooting
18. Configuring Custom Connections
18.1. Working with connection properties
18.1.1. Enabling or disabling a board fileentry
18.1.2. Restoring board file entry defaults
18.2. Configuring the target
18.2.1. Viewing changes
19. RTOS Support
19.1. About Real Time Operating Systems(RTOSs)
19.1.1. Debugging an RTOS application
19.2. Using RealView Debugger RTOS support
19.2.1. Enabling RTOS support
19.2.2. Basic RTOS configuration options
19.2.3. Connecting to the target and loadingan image
19.3. Associating threads with views
19.3.1. Selecting threads from the thread list
19.3.2. The current thread
19.3.3. Attaching and unattaching windows
19.3.4. Manipulating registers and variables
19.4. Using the Resource Viewer window
19.5. Working with threads in the ProcessControl pane
19.6. RTOS resource CLI commands
A. Workspace Settings Reference
A.1. DEBUGGER
A.1.1. Command
A.1.2. Disassembler
A.1.3. Board_file
A.2. CODE
A.2.1. Pos_size
A.2.2. Button
A.2.3. Asm_type
A.3. ALL
A.3.1. Text
A.3.2. Search
A.3.3. Edit
B. Project Properties Reference
B.1. PROJECT group
B.1.1. Top-level PROJECT groupsettings
B.1.2. Command_Open_Close group
B.1.3. Modification_History group
B.2. PROJECT group for a Container project
B.3. SETTINGS group
B.3.1. Top-level SETTINGS group values
B.3.2. Image_load group
B.3.3. Auto_Set_Breaks group
B.3.4. Named_Breaks group
B.3.5. Runtime_Control group
B.4. CONFIGURATION group
B.5. COMPILE group
B.5.1. Top-level COMPILE groupsettings
B.5.2. Sources group
B.5.3. Preprocessor group,ARM-specific
B.5.4. Listings group, ARM-specific
B.5.5. Messages group, ARM-specific
B.5.6. Messages group for project built withRVCT v1.2 or ADS v1.2
B.5.7. Compilation group,ARM-specific
B.5.8. Optimization group, ARM-specific
B.5.9. Output_Control group, ARM-specific
B.6. ASSEMBLE group
B.6.1. Top-level ASSEMBLE group
B.6.2. Sources group
B.6.3. Preprocessor group, ARM-specific
B.6.4. Listings group, ARM-specific
B.6.5. Messages group, ARM-specific
B.6.6. Assembly group, ARM-specific
B.7. CUSTOM group
B.8. BUILD group
B.8.1. Top-level BUILD group settings
B.8.2. Listings group, ARM-specific
B.8.3. Messages group, ARM-specific
B.8.4. Link_Advanced group,ARM-specific
B.8.5. Symbol_Control group, ARM-specific
B.8.6. Pre_Post_Link group
B.8.7. RVDEBUG_Commands group
B.9. BUILD_LIB group
B.9.1. Top-level BUILD_LIB group
B.9.2. Listings group, ARM-specific
B.9.3. Messages group, ARM-specific
B.9.4. Pre_Post_Lib group
B.9.5. RVDEBUG_Commands group
B.10. MAKEFILE group
B.10.1. Using your own make command
C. Connection Properties Reference
C.1. Generic settings
C.2. Target configuration reference
C.2.1. The Advanced_Information block
C.2.2. BOARD, CHIP, and COMPONENT settings
C.3. Custom connection reference
C.3.1. Connections and targets
C.3.2. Board file (brd file)
C.3.3. CONNECTION settings
C.3.4. DEVICE settings
Glossary

List of Figures

2.1. Connection Control window
2.2. The Connection Control check box
2.3. Collapsed, active connection display
2.4. Vehicle menu
2.5. Target menu
2.6. Connection context menu
2.7. Connect Mode selection box
2.8. Failing to make a connection
2.9. Disconnection menu
2.10. Disconnect confirmation
2.11. Disconnect reconfiguration or retry
2.12. Disconnect Mode selection box
3.1. Load File to Target dialog box
3.2. Connection prompt
3.3. Code window with image loaded
3.4. Image details in the Process Controlpane
3.5. Auto-projects in the Process Controlpane
3.6. Changing auto-project settings
3.7. Project menu
3.8. Multiple images in the Process Controlpane
4.1. Debug menu
4.2. Execution Control menu
4.3. Output files recording
4.4. Close log and journal files selectionbox
4.5. Source Search Paths dialog box
5.1. Example hardware break characteristics
5.2. Setting a breakpoint quickly on aline
5.3. Setting a breakpoint quickly on astatement
5.4. Setting a breakpoint quickly on aninstruction
5.5. Setting a breakpoint quickly on abranch instruction
5.6. Working with breakpoint units
5.7. Simple Breakpoints menu
5.8. Set Address/Data Break/Tracepointdialog box
5.9. Breakpoint New Qualifiers menu
5.10. Breakpoint New Actions menu
5.11. Simple Break if X dialog box
5.12. Simple Break if X, N times dialogbox
5.13. Simple Break if X, when Y is Truedialog box
5.14. Named breakpoints list
5.15. Global Breakpoints list selectionbox
5.16. Breakpoint actions and qualifiers
5.17. Breakpoint macro entry prompt
5.18. Set breakpoint with macro attached
5.19. Set Address/Data Break/Tracepointdialog box
5.20. Configuring hardware tests
5.21. Address Range and Mask menu
5.22. Value Range and Mask menu
5.23. Complex Breakpoints menu
5.24. HW Break if in Range dialog box
5.25. HW While in func/range, Break ifX dialog box
5.26. HW break if X, then if Y dialog box
5.27. HW Break on Data Value match dialogbox
5.28. Break/Tracepoints pane
5.29. Breakpoints in the Break/Tracepointspane
5.30. Hardware breakpoints in the Break/Tracepointspane
5.31. Break/Tracepoints menu
5.32. New/Edit Favorite dialog box
5.33. Adding a new favorite
6.1. Map context menu
6.2. Add/Copy/Edit Memory Map dialog box
6.3. Memory mapped
6.4. Colors in the memory map
7.1. Register pane
7.2. Setting enumeration values
7.3. Internal variables for an ARM7TDMIusing RealView ICE Micro Edition
7.4. Memory start address selection box
7.5. Memory value (RAM) context menu
7.6. Example memory display
7.7. Viewing the stack
7.8. Multistatement details in the CallStack pane
7.9. Watch pane with watches
7.10. Watches in the Watch pane
7.11. New/Edit Favorite dialog box
7.12. Existing watches in the FavoritesChooser/Editor
7.13. Adding a new favorite
8.1. Memory/Register Operations menu
8.2. Flash Memory Control dialog box
8.3. Interactive Memory Setting dialogbox
8.4. Upload/Download file from/to Memorydialog box
8.5. Fill Memory with Pattern dialog box
8.6. Flash memory details
9.1. Module/File List dialog box
9.2. Forcing scope
9.3. Function List dialog box
9.4. The Variable List
9.5. C++ symbols in the Symbol Browserpane
10.1. Creating a macro
10.2. Editing a macro body
11.1. Close Open Objects selection box
11.2. Workspace Options window
11.3. Example Workspace Options
12.1. Rebuilding an application
12.2. Build-Tool Properties window
12.3. Add project source file selectionbox
12.4. Merging options selection box
12.5. Building an object file
12.6. Building an image
12.7. Project Properties window
12.8. Example Configuration Summary window
12.9. Customizing the build
12.10. Adding an object file
12.11. Project Properties window for interworkingproject
12.12. Base settings and build target configurationsfor a COMPILE group
12.13. Project Control dialog box
12.14. Process tab in the Process Controlpane
12.15. User-defined projects in the ProcessControl pane
12.16. Auto-projects in the Process Controlpane
12.17. Specifying autobinding
12.18. Autobound projects in the ProjectControl
12.19. Connection selection box
12.20. Container projects in the ProjectControl
12.21. Mixing projects in the Process Controlpane
12.22. Mixing projects in the Project Controldialog box
13.1. File Editor pane
13.2. Editing Controls menu
13.3. Editor Buffer List
13.4. Save Multiple dialog box
13.5. Using a standalone editor
13.6. Insert Template dialog box
14.1. Find dialog box
14.2. Find in Files dialog box
14.3. Pair Matching dialog box
15.1. Source control menu for locked files
15.2. Source control menu for read-writefiles
15.3. Source control command prompt
15.4. Source control settings in theworkspace
15.5. Custom source control commands inthe workspace
16.1. Connection Properties window
16.2. Connection entries in the ConnectionControl window
17.1. Board file configuration file structure
17.2. Connection Properties window, showinguse of BoardChip_name setting
17.3. Saving an existing *.bcd file witha new name
17.4. Deleting the original contents ofthe copied file
17.5. Adding a new group to a *.bcd file
17.6. Viewing the new group in the *.bcdfile
17.7. Linking one connection to one board
17.8. Linking a board
17.9. Linking one connection to two boards
17.10. Linking a second board
17.11. Linking one board into another board
17.12. MCUeval tab in the Register pane
17.13. The default Memory_block settingsfor ARMulator
17.14. Viewing the contents of the new group
17.15. New memory map in the Process Controlpane
17.16. Configuring REGS
17.17. Creating enumerations
17.18. Creating bit field descriptions
17.19. The MYREG group
17.20. MYREG in the Register pane
17.21. Creating a new memory block
17.22. Creating a map rule
17.23. Settings for the second map rule
17.24. New memory block in the Map tab
17.25. Settings in the Stack_Heap group
17.26. Relating top_of_memory to singlesection program layout
17.27. Output pane after configuration
17.28. The Flash Memory Control dialog
18.1. Connection properties entries inthe Connection Control window
18.2. Enabling or disabling a board fileentry
18.3. Restoring board file entry defaults
18.4. Editing the configuration file inthe Connection Properties window
19.1. RTOS group in the Connection Propertieswindow
19.2. Example thread list
19.3. Resource Viewer showing thread details
19.4. The Thread tab in the Process Controlpane
B.1. PROJECT group
B.2. PROJECT group settings valuesfor a Container project
B.3. SETTINGS group
B.4. CONFIGURATION group
B.5. Top level COMPILE settings
B.6. Top level ASSEMBLE group
B.7. CUSTOM group
B.8. BUILD group
B.9. BUILD_LIB group
B.10. MAKEFILE group
C.1. Viewing generic settings
C.2. How Components, Boards, and Chips fit together

List of Tables

4.1. Keyboard shortcuts
5.1. Breakpoint menu mappings
9.1. Browser filter metacharacters
10.1. Predefined macros
12.1. Project settings groups
13.1. Text coloring scheme
13.2. Find menu options
13.3. Editing Controls 
13.4. Edit settings in workspace
13.5. ex commands supported in vi mode
13.6. Additional ex commands supported in vi mode
14.1. Setting temporary search settings
14.2. Search settings in workspace
14.3. Regular expression metacharacters
14.4. Using repetition operators
15.1. Src_ctrl settings in workspace
15.2. Custom source control commands in workspace
A.1. Command settings
A.2. Disassembler settings
A.3. Pos_size settings
A.4. Button settings
A.5. Source_coloring settings
A.6. Text settings
A.7. Search settings
A.8. Backup settings
A.9. Tab_conv settings
A.10. Edit settings
B.1. PROJECT group
B.2. Command_Open_Close group
B.3. Create group
B.4. SETTINGS group
B.5. Image_load group  
B.6. Auto_Set_Breaks group
B.7. Named_Breaks group
B.8. Runtime_Control group
B.9. Vectors group
B.10. CONFIGURATION group
B.11. COMPILE group
B.12. Sources group
B.13. Preprocessor group
B.14. Precompile_Headers group
B.15. Listings group
B.16. Messages group
B.17. Warning group
B.18. Error group
B.19. Compilation group
B.20. Checking group
B.21. APCS group
B.22. Alignment group
B.23. Language group
B.24. Cpp group
B.25. Optimization group
B.26. Output_Control group
B.27. ASSEMBLE group
B.28. Sources group
B.29. Preprocessor group
B.30. Listings group
B.31. Messages group
B.32. Assembly group
B.33. APCS group
B.34. CUSTOM group
B.35. BUILD group
B.36. Listings group
B.37. Messages group
B.38. Link_Advanced group
B.39. Symbol_Control group
B.40. Pre_Post_Link group
B.41. RVDEBUG_Commands group
B.42. BUILD_LIB group
B.43. Listings group
B.44. Messages group
B.45. Pre_Post_Lib group
B.46. RVDEBUG_Commands group
B.47. MAKEFILE group

Proprietary Notice

Words and logos marked with ® or ™ are registered trademarks or trademarksowned by ARM Limited. Other brands and names mentioned herein maybe the trademarks of their respective owners.

Neither the whole nor any part of the information containedin, or the product described in, this document may be adapted orreproduced in any material form except with the prior written permissionof the copyright holder.

The product described in this document is subject to continuousdevelopments and improvements. All particulars of the product andits use contained in this document are given by ARM in good faith.However, all warranties implied or expressed, including but notlimited to implied warranties of merchantability, or fitness forpurpose, are excluded.

This document is intended only to assist the reader in theuse of the product. ARM Limited shall not be liable for any lossor damage arising from the use of any information in this document,or any error or omission in such information, or any incorrect useof the product.

ConfidentialityStatus

This document is Non-Confidential. The right to use, copyand disclose this document may be subject to license restrictionsin accordance with the terms of the agreement entered into by ARMand the party that ARM delivered this document to.

Product Status

The information in this document is final, that is for a developedproduct.

Revision History
Revision A May 2003 Release for RVDK v1.0
Revision B March2004 Release for RVDK v1.0.1
Copyright © 2003, 2004 ARM Limited. All rights reserved. ARM DUI 0234B
Non-Confidential