3.2. Finding options on the main menu

This section provides a summary of the main menu options available from the Code window (see Figure 3.1) that enable you to:

Note

Some menu options are not enabled unless you have suitable support, for example the View → Threads tab option.

The menus available from the main menu bar are:

File

Displays the File menu.

The File menu also enables you to examine, and change, your workspace settings.

When you are using the File menu the menu option Close Window is not enabled when the default Code window is the only window. This is the main debugging and editing window, and it must be open throughout your debugging session. Close the Code window to close down RealView Debugger.

Edit

Displays the Edit menu. This menu enables you to work with source files as you develop your application. It includes options to:

  • define how source code is displayed in the File Editor pane.

  • enable you to work with source files and perform searches on those files as you debug your image

  • access the various browsers in RealView Debugger.

View

Displays the View menu. This menu enables you to set up new windows and panes as you are working with target connections.

To use custom windows, you must have an appropriate third-party custom window plugin. A custom window plugin can be designed to start automatically when RealView Debugger starts. If you only have plugins of this type, then the Custom Windows option remains disabled. Otherwise, if a plugin is designed not to start automatically, then the Custom Windows option is enabled. In addition, an option is added to the submenu to enable you to start the custom window plugin. For instructions on installing third-party custom window plugins, and how to use them, see your Vendor documentation.

Target

Displays the Target menu. This menu enables you to connect and disconnect from debug targets, configure your connections, load images, and attach the Code window to a connection.

Project

Displays the Project menu. This menu enables you to work with projects so that you can organize your source files, model your build process, and share files with other developers. This can be used in conjunction with the Build menu to rebuild images.

These features are described in full in the chapter that describes working with projects in RealView Developer Kit v2.2 Project Management User Guide.

Build

Displays the Build menu. This menu enables you to build files, or groups of files, to create your image ready for loading to a target.

For details of this menu see the chapter that describes building applications in RealView Developer Kit v2.2 Project Management User Guide.

Debug

Displays the Debug menu. This menu includes the main facilities you use during a debugging session, such as setting up breakpoints and tracepoints, controlling program execution, and program Flash.

Tools

Displays the Tools menu. This menu enables you to:

  • set up Analyzer and Tracing features

  • add and configure macros for use during debugging

  • log information to the Log, Journal and STDIO log files

  • run CLI commands from script files

  • examine, and change, your global configuration options.

The Tools menu also provides access to options for Analysis and Profiling.

Note

Supported by selected simulators from Ceva Inc., the Simulation Control option is not available in this release.

Help

Displays the Help menu.

This menu gives you access to the RealView Debugger online help, to web downloads pages, and displays details of your version of RealView Debugger. You can also use this menu to create and submit a Software Problem Report (SPR).

Copyright © 2005, 2006 ARM Limited. All rights reserved.ARM DUI 0276B
Non-Confidential