RealView ® DeveloperKit Project Management User Guide

Version 2.2


Table of Contents

Preface
About this book
Intended audience
Examples
Using this book
Typographical conventions
Further reading
Feedback
Feedback on RealView Debugger
Feedback on this book
1. Overview of Project Management
1.1. What is a project?
1.1.1. Types of project
1.2. User-defined projects
1.2.1. Types of user-defined project
1.3. Auto-projects
1.4. Organizing user-defined projects
1.4.1. Project size
1.4.2. Deleting user-defined projects
1.5. Project properties
1.6. Build tools for user-defined projects
1.7. Build target configurations
1.8. Makefiles
1.8.1. Standard and Library project makefiles
1.8.2. Custom project makefiles
1.9. Project binding
1.9.1. Autobinding
1.10. Projects in the workspace
1.11. Projects in Connection Properties
2. Working with Projects
2.1. Using the Project menu
2.1.1. Active project
2.1.2. Menu options
2.2. Opening a user-defined project
2.2.1. Default binding
2.2.2. Upgrading the project
2.3. Generated makefiles
2.3.1. Viewing the makefile
2.4. Project properties
2.5. Adding files to a user-defined project
2.5.1. Adding files using the Project menu
2.5.2. Adding files using the Project Propertieswindow
2.6. Upgrading the projecttoolchain
2.7. Closing a user-defined project
2.7.1. Project binding
2.7.2. Working with images
3. Creating New Projects
3.1. Creating a new user-defined project
3.1.1. Before you start
3.2. Common steps for creating a user-definedproject
3.3. Steps for creating a Standard or Libraryproject
3.4. Steps for creating a Custom project
3.4.1. The MAKEFILE group
3.4.2. Using your own make command
3.5. Steps for creating a Container project
3.6. Steps for copying an existing user-definedproject
3.7. Customizing and building your project
3.8. Merging auto-project settings intoa project
3.8.1. Merging options
3.8.2. Common steps for merging auto-projectsettings
3.8.3. Steps for merging settings into aStandard project
3.8.4. Steps for merging settings into aCustom project
3.8.5. Customizing and building your project
4. Using the Project Properties Window
4.1. Viewing project properties
4.2. Project Properties window
4.2.1. List of Entries and Settings Values
4.2.2. Project settings groups
4.2.3. Working with project settings groups
4.3. Viewing the Configuration Summary
5. Customizing Projects
5.1. Working with the examples
5.1.1. Before you start
5.1.2. Connecting to a debug target
5.1.3. Using genmake
5.1.4. Changing settings
5.2. Changing build tools for a specificuser-defined project
5.3. Working with source files
5.3.1. Adding source files to a project
5.3.2. Removing source files from a project
5.3.3. Compiling a specificsource file
5.3.4. Excluding source files from a build
5.3.5. Specifying source search paths
5.3.6. Source path mappings
5.4. Working with object files
5.4.1. Changing the location of object files
5.4.2. Adding object files
5.5. Adding library files
5.5.1. Removing library files
5.6. Specifying paths to include files
5.7. Configuring linker options
5.7.1. Specifying linker options and scatterloading
5.7.2. Adding prelink and postlink commands
5.8. Specifying breakpoints
5.9. Customizing the build
5.9.1. Adding a custom build group
5.9.2. Running the custom build
5.10. Interworking ARM and Thumb
5.10.1. Running the interworking example
5.10.2. Setting compiler options for interworking
5.10.3. Displaying code sizes
5.11. Using MS-DOS applications
5.11.1. Configuring tools support
5.11.2. Using MS-DOS namesunder Windows
6. Managing Projects in the Code Window
6.1. Using the Project Control dialog box
6.1.1. Viewing the Project Control dialogbox
6.1.2. Working with the Project Control dialogbox
6.2. Managing projects in the Process Controlpane
6.2.1. Displaying the Process Control pane
6.2.2. Working with user-defined projects
6.2.3. Working with auto-projects
6.2.4. Project contextmenus
7. Building Applications
7.1. Using the Tools menu
7.1.1. Active project
7.1.2. Tools menu build options
7.1.3. Other Tools menu options
7.1.4. Using the Actions toolbar
7.2. Managing your build tools
7.3. Using the Build-Tool Properties window
7.3.1. Genmake location file
7.4. Defining build tools
7.4.1. Working with open projects
7.5. Building files and images
7.5.1. Building an object file
7.5.2. Building an executable image or libraryfile
7.5.3. Resetting line numbers
7.6. Using the Build dialog box
7.7. Finding build errors
7.8. Using a build model
7.8.1. Defining rules for a build model
8. Managing Build Target Configurations
8.1. About build target configurations
8.1.1. Defining build target configurations
8.1.2. Base settings
8.1.3. Viewing build target configurations
8.1.4. Active build target configuration
8.2. Working with the examples
8.2.1. Before you start
8.2.2. Connecting to a debug target
8.2.3. Changing settings
8.3. Working with build target configurations
8.3.1. Creating a configuration
8.3.2. Deleting a configuration
8.3.3. Changing the active configuration
8.3.4. Changing the order of configurations
8.4. Working with settings in build targetconfigurations
8.4.1. Assigning a specificsetting to a configuration
8.4.2. Removing a setting from a configuration
8.4.3. Assigning multiple settings to a specificconfiguration
9. Project Binding
9.1. Types of binding
9.1.1. Default binding
9.1.2. Autobinding
9.2. Viewing project binding
9.2.1. Viewing autobound projects
9.3. Forcing binding
9.3.1. Autobound projects
9.3.2. Forcing unbinding
9.4. Effects of binding
9.5. Effects of unbinding
9.6. Connecting and disconnecting
10. Working with Multiple Projects
10.1. Working with multiple projects
10.2. Active projects
10.2.1. Changing the active project
10.3. Working with Container projects
10.3.1. Opening a Container project
10.3.2. Working with the Project Control dialogbox
10.3.3. Nesting Container projects
10.4. Working with auto-projects
10.4.1. Working with user-defined projects and auto-projects
10.5. Closing projects
10.6. Connecting and disconnecting
11. Editing Source Code
11.1. About the File Editor
11.1.1. Using the File Editor pane
11.1.2. Working with multiple files
11.1.3. Editing binary files
11.2. Configuring the File Editor
11.3. Editing text
11.3.1. Basic text editing
11.3.2. Formatting text
11.3.3. Undoing changes
11.3.4. Using drag-and-drop
11.4. Managing your editing session
11.4.1. Using Editing Controls
11.4.2. Setting source search paths
11.4.3. Changing your workspace settings
11.5. Using templates
11.5.1. Inserting templates
11.5.2. Creating templates
11.5.3. Template examples
12. Searching and Replacing Text
12.1. About finding and replacing text
12.2. Searching and replacing text
12.2.1. Searching for text
12.2.2. Searching and replacing text
12.2.3. Searching for selected text
12.3. Searching multiple files
12.3.1. Displaying the Find in Files dialogbox
12.3.2. Components of the Find in Files dialogbox
12.3.3. Abandoning the search
12.3.4. Viewing search results
12.4. Working with functions
12.4.1. Jumping to a function
12.4.2. Jumping to a function definition
12.4.3. Returning from a jump
12.5. Pair matching
12.5.1. Searching pairs
12.5.2. Matching pairs
12.5.3. Matching nested pairs
12.5.4. Enclosing
12.6. Configuring searches in the workspace
12.7. Using regular expressions
12.7.1. About special operators
12.7.2. Searching with regular expressions
13. Working with Version Control Systems
13.1. Defining the version control tool
13.2. Using a version control tool
13.2.1. Changing the status of controlledfiles
13.2.2. Using source control commands
13.2.3. Setting up a prompt
13.3. Configuring a custom version controltool
13.3.1. Changing your workspace settings
13.3.2. Specifying custom commands
Glossary

List of Figures

2.1. Project menu
2.2. Rebuilding an application
2.3. Add project source file selectionbox
2.4. Upgrade Project selection box
2.5. Upgrade Project ToolChain dialogbox
3.1. Merging options selection box
4.1. Project Properties window
4.2. Groups in the Project Properties window
4.3. Example Configuration Summary window
5.1. Using an escape character
5.2. Source search prompt
5.3. Autoconfigured search rules in theProject Properties window
5.4. Search rules in the Project Propertieswindow
5.5. New search rules in the Project Propertieswindow
5.6. Source search paths and remappingsin the Project Properties window
5.7. Linker options in the Project Propertieswindow
5.8. Linker output in the Output pane
5.9. Named Breakpoints selection box
5.10. Customizing the build
5.11. Project Properties window for armtothumbproject
6.1. Project Control dialog box
6.2. Process tab in the Process Controlpane
6.3. User-defined projects in the ProcessControl pane
6.4. Auto-projects in the Process Controlpane
7.1. Build-Tool Properties window
7.2. Building an object file
7.3. Building an image
8.1. Base settings and build target configurationsfor a COMPILE group
9.1. Specifying autobinding
9.2. Autobound projects in the ProjectControl
9.3. Connection selection box
10.1. Project Control dialog box
10.2. Container projects in the ProjectControl
10.3. Mixing projects in the Process Controlpane
10.4. Mixing projects in the Project Controldialog box
11.1. File Editor pane
11.2. Save Multiple dialog box
11.3. Edit settings in the workspace
11.4. Insert Template dialog box
12.1. Find dialog box
12.2. Find in Files dialog box
12.3. Jump to Function dialog box
12.4. Pair Matching dialog box
12.5. Search settings in the workspace
13.1. Source control menu for locked files
13.2. Source control menu for read-writefiles
13.3. Source control command prompt
13.4. Source control settings in theworkspace
13.5. Custom source control commands inthe workspace

ProprietaryNotice

Words and logos marked with ® or ™ are registered trademarks or trademarksowned by ARM Limited. Other brands and names mentioned herein maybe the trademarks of their respective owners.

Neither the whole nor any part of the information containedin, or the product described in, this document may be adapted orreproduced in any material form except with the prior written permissionof the copyright holder.

The product described in this document is subject to continuousdevelopments and improvements. All particulars of the product andits use contained in this document are given by ARM in good faith.However, all warranties implied or expressed, including but notlimited to implied warranties of merchantability, or fitness forpurpose, are excluded.

This document is intended only to assist the reader in theuse of the product. ARM Limited shall not be liable for any lossor damage arising from the use of any information in this document,or any error or omission in such information, or any incorrect useof the product.

ConfidentialityStatus

This document is Non-Confidential. The right to use, copyand disclose this document may be subject to license restrictionsin accordance with the terms of the agreement entered into by ARMand the party that ARM delivered this document to.

Product Status

The information in this document is final, that is for a developedproduct.

Revision History
Revision B April 2005 Releasefor RVDK v2.2
Revision C January 2006 Includestrace support
Copyright © 2005, 2006 ARM Limited. All rights reserved. ARM DUI 0291C
Non-Confidential