Using the Configure Model Parameters dialog box

If you had not yet loaded a model at the time that Model Debugger starts:
  1. Select File > Load Model.
  2. In the Load Model dialog box that appears, locate and select the required model, then click Open.
  3. A dialog box appears:
Figure 2-2 Configure Model Parameters dialog box
Configure Model Parameters dialog box

If you had already loaded a model before Model Debugger starts, Model Debugger checks the available components and opens a similar dialog box.

Note

The exact contents and titles of the panes might differ because they depend on the model.
The Configure Model Parameters dialog box has the following sections:
Parameter category
This pane contains a hierarchical list of the component parameters by category. Click the + symbol to expand the view or the - symbol to collapse the view.
Parameter setting
The parameter values are displayed in the right-hand pane.
Use the box in the lower left corner of the window to toggle between hexadecimal or decimal views.

Note

The name of this pane varies, depending on the model, but its purpose and usage is the same in all cases.
To view all of the configuration parameters as a single list, click the List View tab. The Tree View is similar, but shows the same parameters in a grouped hierarchy.
Figure 2-3 Configure Model Parameters dialog box, List View tab
Configure Model Parameters dialog box, List View tab

Set the parameters for the model and click OK to close the Configure Model Parameters dialog box.
Non-ConfidentialPDF file icon PDF versionARM DUI0314Q
Copyright © 2007-2014 ARM. All rights reserved.