B.3. Dependencies for Red Hat version 5

Table B.2 lists the library files and their dependencies for release 5, codename Tikanga.

The distributor ID for this release is RedHatEnterpriseClient.

Note

The SDL library /usr/lib/libSDL-1.2.so.0 is present, but ARM recommends that you do not use this version and instead change LD_LIBRARY_PATH to include the libSDL from the deployed package.

Table B.2. Dependencies for Red Hat v5

Library fileDependenciesRequired for
/lib/ld-linux.so.2glibc-25-12Fast Model Tools and Portfolio
/lib/libasound.so.2alsa-lib-1.0.12-3.el5Fast Model Portfolio only
/lib/libaudiofile.so.0audiofile-0.2.6-5Fast Model Portfolio only
/lib/libc.so.6glibc-2.5-12Fast Model Tools and Portfolio
/lib/libdl.so.2glibc-2.5-12Fast Model Tools and Portfolio
/lib/libgcc_s.so.1libgcc-4.1.1-52.el5Fast Model Portfolio only[a]
/lib/tls/libm.so.6glibc-2.5-12Fast Model Tools and Portfolio
/lib/tls/libpthread.so.0glibc-2.5-12Fast Model Tools and Portfolio
/lib/tls/librt.so.1glibc-2.5-12Fast Model Tools and Portfolio
/usr/bin/makedependimake-1.0.2-3Fast Model Tools only
/usr/lib/libesd.so.0esound-0.2.36-3Fast Model Tools and Portfolio
/usr/lib/libICE.so.6 libICE-1.0.1-2.1Fast Model Tools and Portfolio
/usr/lib/libncurses.so.5ncurses-5.5-24.20060715Fast Model Tools and Portfolio
/usr/lib/libSM.so.6libSM-1.0.1-3.1Fast Model Tools and Portfolio
/usr/lib/libstdc++.so.6libstdc++-4.1.1-52.el5Fast Model Portfolio only
/usr/lib/libX11.so.6libX11-1.0.3-8.el5Fast Model Tools and Portfolio
/usr/lib/libXau.so.6libXau-1.0.1-3.1Fast Model Tools and Portfolio
/usr/lib/libXcursor.so.1libXcursor-1.1.7-1.1Fast Model Tools and Portfolio
/usr/lib/libXdmcp.so.6libXdmcp-1.0.1-2.1Fast Model Tools and Portfolio
/usr/lib/libXext.so.6libXext-1.0.1-2.1Fast Model Tools and Portfolio
/usr/lib/libXfixes.so.3libXfixes-4.0.1-2.1Fast Model Tools and Portfolio
/usr/lib/libXrender.so.1libXrender-0.9.1-3.1Fast Model Tools and Portfolio
/usr/lib/libz.so.1zlib-1.2.3-3Fast Model Portfolio only

[a] The libgcc_s.so/libstdc++.so libraries are present in Red Hat 5, but ARM recommends that you do not use this version. Copy the versions included in Fast Models to the deployment package and set LD_LIBRARY_PATH.


Copyright © 2007-2009 ARM Limited. All rights reserved.ARM DUI 0370H
Non-Confidential