3.2.1. Menu bar

The main menu provides access to System Canvas functions and commands.

File menu

The File menu has the following options:

New Project

Use the New Project entry to create a new model project. See New Project dialogs.

Load Project

This option opens an existing project.

Close Project

This operation closes the currently opened project. If there are pending changes, the Save changes dialog is displayed.

Save Project

This command saves the changes made to the current project.

Save Project As

This command saves the current project to a new location and name.

New File

This displays the New File dialog to create a new file. Select the type from the File type drop-down list.

Open File

This displays the Open File dialog to create a new file. Filter the types to display by selecting the type from the File type drop-down list. If the file type is not LISA, you can open the file as text in the source editor.

Close File

This operation closes the currently open LISA file. If there are pending changes, the Save changes dialog is displayed.

Save File

This command saves the changes made to the current LISA file.

Save File As

This command saves the current LISA file to a new location and name.

Save All

This command saves the changes made to the current project and any modified LISA files.

Print

This command prints the contents of the Block Diagram window. A dialog displays to enable you to select the destination printer.

Preferences

Use this option to modify the user preferences.

Recently Opened Files

A list of the sixteen most recently opened LISA files. Click on a list entry to open the file.

To remove a file from the list, move the mouse cursor over the file name and press the Delete key or right click and select Remove from list from the context menu.

Recently Opened Projects

A list of the sixteen most recently opened projects. Click on a list entry to open the project.

To remove a project from the list, move the mouse cursor over the project name and press the Delete key or right click and select Remove from list from the context menu.

Exit

End System Canvas. If you have modified files or projects, a dialog prompts you to save your changes. You can choose to not have the dialog presented in future by selecting Do not show this message again. To re-enable the dialog, edit the Preferences. See Suppressed Messages.

Edit menu

The Edit menu has the following options:

Undo

Undo the last change to a file in the Source window or to the layout in the Block Diagram view. Up to 42 actions can be undone. The following actions can be undone:

  • adding an object such as a component, label, or connection

  • pasting or duplicating objects

  • cutting or deleting objects

  • editing object properties

  • moving objects

  • resizing objects.

Note

Undo and Redo operations can affect block diagram view zoom and scroll actions.

Undo and Redo typically work in the usual intuitive way, but the following special case requires explanation:

  1. Change the system in the Block Diagram view by, for example, adding a RAMDevice component with name RAM.

  2. Switch to Source view. The text RAM : RAMDevice(); is present in the composition section.

  3. Change the code by removing the line RAM : RAMDevice(); from the Source view.

  4. Change the code by adding, for example, the line PVS : PVBusSlave(); to the Source view.

  5. Click on the Block Diagram tab. The change to the source code is reflected by the RAM component being replaced by the PVS component.

  6. Select Undo from the Edit menu. This Block Diagram view shows the system as it was before step 2. RAM is present but PVS is not.

  7. Select Redo from the Edit menu. This Block Diagram view shows the system as it was before step 6. PVS is present but RAM is not.

Redo

Redo the last undone change. This cancels the result of selecting Undo. Selecting Redo multiple times cancels multiple Undo actions. See the description for Undo for more information.

Cut

Cut the marked element and place it into the copy buffer.

Copy

Place the marked element into the copy buffer.

Paste

Paste the content of the copy buffer at the current cursor position.

Duplicate

Duplicate the marked content.

Delete

Delete the marked element.

Select All

Select all elements.

Edit Mode

Change the Workspace to Edit Mode. Components can be selected with the cursor.

Connect Ports Mode

Select connection mode. The cursor is used to connect components.

Pan Mode

Select movement mode. The cursor is used to move the entire system in the Workspace window.

Search menu

The Search menu has the following options:

Find

Selecting Find opens a dialog that allows searching for a string in a currently active window. The Active window is highlighted by a thick black frame around it. See Find and Replace dialogs.

Find Next

The last defined search is repeated to find the next occurrence.

Find Previous

The last defined search is repeated, but the search direction is backwards in the document.

Replace

Selecting Replace opens the Find dialog with replace controls displayed. This lets you replace strings in a text document. The Replace feature is only available if the active window is a source editor. See Find and Replace dialogs.

Go To Line

Selecting this option displays a dialog that enables you to specify a line number in the currently open LISA file. This option is only enabled in the Source view.

Note

You can also use the search icons displayed at the top right of the application window to search for text. Enter the text to search for in the text box to the right of the search icons. As you enter text, an incremental search is performed in the active window.

View menu

The View menu has the following options:

Show Grid

Display the grid in the Workspace window. Using the grid simplifies component alignment.

Zoom In

Increase the magnification for the Workspace window to show part of the system in more detail.

Zoom Out

Decrease the magnification for the Workspace window to show more of the system.

Zoom 100%

Change the magnification for the Workspace window to the full workspace canvas area.

Zoom Fit

Change the magnification for the Workspace window to fit the entire system into the workspace canvas area.

Zoom Fit Selection

Change the magnification for the Workspace window to fit the selected portion of the system into the workspace canvas area.

Object menu

Use the Object menu to modify the system or a component in the system. The Object menu has the following options:

Open Component

This option opens the source for the component that has been selected in the Workspace.

Add Component

This option displays a dialog that contains all the available components that can be added to the diagram.

Add Label

This option changes the mouse cursor into a default label. To add a label, move the label to the location desired and click the left mouse button. The label properties dialog is displayed to enable you to change the label text and properties.

Add Port

This option displays the External Port dialog used to specify the type of port to add.

Mirror Self Port

This option switches the direction of drawing the external port. It does not reverse the signal direction, so a master port remains a master port. If an unconnected port is not selected, this option is disabled.

Expand Port

If a port array is selected, this option is enabled. Select it to display all of the individual port elements. Port arrays with more than eight elements are collapsed by default.

Note

Ports with a large number of elements might expand so that all elements appear on top of one another. Click and drag to move the individual port elements to separate locations. Alternatively, collapse the port, increase the component size, then expand the port again.

Collapse Port

If a port array is selected, this option is enabled. Select it to hide the individual port elements and only display the top-level port name. Ports with eight or fewer elements are expanded by default.

Hide Port

Use this option to disable the selected port and make it invisible in the Block Diagram window.

Hide All Unconnected Ports

This option hides all ports that are not connected to a component.

Show/Hide Ports of Protocol Types...

This option hides all ports that use a specified protocol. Select the protocols to filter from the displayed Show/Hide Connection Types dialog.

Show All Ports

This option shows all ports that have previously been hidden. This might result in overlapping port symbols if there is not enough space for displaying all of the hidden ports.

Autoroute Connection

This option removes any manually placed points or manually moved line segment end points from the currently selected connection and reroutes the connection.

Autoroute All Connections

This option removes any manually placed points or manually moved line segment end points from all connections and reroutes the connections.

Documentation

This option opens the PDF file that contains the documentation for the selected component.

Object Properties

This option displays the Component Instance Properties dialog to view and edit the properties for the selected component.

Note

If a component is not selected, the Component Model Properties dialog is displayed.

Project menu

The Project menu has the following options:

Check System

Use this entry to check if the system being developed has any errors or missing information. This feature cannot check everything, but does give useful feedback.

Generate System

Generate a system. After generation finishes, click Build System and Debug to run the model.

Build System

Compile the system files.

Stop Build

Cancel the build process that is currently active.

Clean

Delete all generated files.

Launch in Model Debugger

Execute simulation under control of Model Debugger.

Run in Model Shell

Execute simulation under control of Model Shell. This option must be enabled from the Preferences dialog as described in Applications.

Kill Model Shell

Stop Model Shell and end the simulation.

Launch Host Debugger

Launch the debugger. The behavior of this entry depends on the operating system:

  • For Windows, Microsoft Visual Studio 2005 or 2008 is launched depending on the configuration. A generated solution file is supplied as an argument that can generate any target. If the system has not already been built, that can be done in Visual Studio.

    You can start a debug session from the Visual Studio session. Command line arguments for isim systems or model_shell can be supplied by from Visual Studio by selecting Project → Properties → Configuration Properties → debugging.

  • For Linux, the executable or script defined in Application Preferences is launched (see Preferences dialog). Only an isim target can be specified as the argument. ARM® recommends this as the preferred way to do source level debugging.

Add Files

Add an existing file to the system.

Add Current File

Add the currently open file to the system.

Refresh Component List

Update the Component List window to show all available components.

Setup Default Directory

Displays the Default Model Repository section of the Preferences window. Use this dialog to select the repositories that will be automatically included in the next new project.

Note

The currently open project is not affected by changes to the default model repository list.

Active Configuration

Select the configuration to use to build the system from the list of project files.

Project Settings

Display the Project Settings dialog.

Help menu

The Help menu has the following options:

User Guide

This option opens this book in Adobe Acrobat Reader.

Model Shell Reference Manual

This option opens the PDF file that contains the Model Shell reference.

LISA Language Reference Manual

This option opens the PDF file that contains the language reference.

System Generator Release Notes

This option opens the text file that contains the release notes.

Documents in $PVLIB_HOME/Docs

This option lists the PDF files that are in the directory $PVLIB_HOME/Docs. The location syntax is the same on both Windows and Linux. The PVLIB_HOME environment variable is set when the Fast Model Portfolio is installed.

End User License Agrement (EULA)

This option opens the HTML file that contains the license agreement.

About

This displays the standard About dialog box displaying version and license information.

System Information

This displays a dialog that contains extended information about the tools and loaded models.

Copyright © 2007-2009 ARM Limited. All rights reserved.ARM DUI 0370H
Non-Confidential