1.1.1. Software requirements

This section lists the software components that must be available to run Fast Models.

Linux

The following software is required for Linux:

Operating system
  • Red Hat Enterprise Linux version 4 or 5 (on either 32 or 64 bit architectures).

  • xorg-x11-devel (makedepend) if using RHEL4.

  • imake-1.0.2-3 (makedepend) if using RHEL5.

Shell

A shell compatible with sh, such as bash or tcsh.

Compiler

gcc version 3.4.3.

gcc version 4.1.2 with GNU binutils 2.17.

Note

To run Fast Models on RHEL 5 with gcc 3.4.3, you must use GNU binutils 2.16. Download an appropriate GNU tool chain from here: ftp://esl-support.arm.com/tools/gnu/binary/enterprise-linux

Note

ARM is planning to deprecate support for gcc 3.4.3 for the Fast Models in a future release. Email support-esl@arm.com for any comments.

Adobe Acrobat reader

Version 8 or higher.

License management utilities

If you are using floating licenses, FLEXlm version 9.2 or higher is required. Newer versions are called FLEXnet.

FLEXnet 10.8 license management utilities are available through a link on the ESL support website, on the same page from which you downloaded your tools. Use the highest version of the license management utilities provided with any ARM tools you are using. If you do not have a copy of these utilities, contact ARM License Support at: license.support@arm.com.

Windows

The following software is required for Windows:

Operating system

Windows XP with Service Pack 2 or Vista (32-bit operating system).

Compiler

Microsoft Visual Studio 2005 with Service Pack 1 or Microsoft Visual Studio 2008 with Service Pack 1 on Windows XP.

Microsoft Visual Studio 2008 with Service Pack 1 on Windows Vista.

The Fast Models tools are compiled with VS2005 SP1. Even if you only use the VS2008 SP1 compiler, you must install the VS2005 SP1 runtime libraries.

Note

Fast Models does not contain the Visual Studio runtime libraries. If Visual Studio is not installed, you must download and install the Microsoft Visual C++ 2005 SP1 (or 2008 SP1) Redistribution Package to run models on your workstation. The service package is available from the Microsoft web site.

Fast Models does not support the Express versions of Microsoft Visual Studio.

Note

  • ARM is planning to deprecate support for Windows Vista for the Fast Models in the next release of Fast Models.ARM is planning to deprecate support for Windows Visual Studio 2005sp1 when support for Visual Studio 2010 is provided. This may be in the next release of the Fast Models product. Please email support-esl@arm.com with any comments.

Adobe Acrobat reader

Version 8 or higher.

License management utilities

If you are using floating licenses, FLEXlm version 9.2 or higher is required. Newer versions are called FLEXnet.

FLEXnet 10.8 license management utilities are available through a link on the ESL support website, on the same page from which you downloaded your tools. Use the highest version of the license management utilities provided with any ARM tools you are using. If you do not have a copy of these utilities, contact ARM License Support by emailing license.support@arm.com.

Note

If you are using Microsoft Windows Remote Desktop (RDP) to access System Canvas or a simulator generated by System Canvas, the type of license you have for Fast Models can restrict use of the product:

  • Floating licenses require a license server and do not have any special restrictions relating to use of Remote Desktop. Such licenses are normally issued to Fast Models users who have purchased the tool.

  • Node-locked licenses are tied to a specific workstation. These licenses do not work over Remote Desktop connections. Node-locked licenses are typically issued to users who are evaluating Fast Models. If this limitation prevents your evaluation of the product, contact license.support@arm.com and request a floating evaluation license.

Copyright © 2007-2010 ARM Limited. All rights reserved.ARM DUI 0370K
Non-ConfidentialID110210