10.23 [Target]ビュー

[ターゲット]ビューでは、ターゲットによってサポートされるブレークポイントのタイプなど、ターゲットのデバッグ機能を表示できます。ただし、この機能を変更することはできません。

図 10-28 [Target]ビュー
[Target]ビュー

列ヘッダを右クリックして表示する列を選択します。以下の列があります。
名前
ターゲット機能の名前。
[Value]
ターゲット機能の値。
[Key]
ターゲット機能の名前。これは、[Commands]ビューのいくつかのコマンドで使用されます。
説明
ターゲット機能の説明。
[すべての列を表示]
すべての列を表示します。
[列をリセット]
表示された列とその幅をデフォルトにリセットします。
デフォルトでは、[Name][Value]、および[Description]の列が表示されます。
[Target]ビューはデフォルトでは表示されません。このビューを追加するには、以下の手順に従います。
  1. DS-5 デバッグパースペクティブで作業していることを確認します。
  2. [ウィンドウ] > [ビューを表示] > [ターゲット]を選択します。

ツールバーとコンテキストメニューのオプション

ツールバーまたはコンテキストメニューには、以下のオプションが用意されています。
[Linked:context]
このビューを[デバッグ制御]ビューで選択した接続にリンクします。これがデフォルトです。または、ビューを別の接続にリンクすることもできます。リンクする接続がドロップダウンリストに表示されていない場合は、まず[デバッグ制御]ビューで接続を選択する必要があります。
[Refresh the Target Capabilities]
ビューを更新します。
[View Menu]
このメニューは以下のオプションから構成されています。
[New Target View]
[ターゲット]ビューの新しいインスタンスを表示します。
[Copy]
選択した機能をコピーします。ブレークポイント機能などのグループの機能をコピーするには、まずそのグループを拡張する必要があります。
このオプションは、機能をテキストエディタにコピーして、将来の参照に備えてその機能を保存する場合に便利です。
[Select All]
ビューで現在拡張されているすべての機能を選択します。
関連する参考文書
章 10  DS-5 デバッグパースペクティブおよびビュー
非機密扱いPDF file icon PDF 版ARM DUI0446VJ
Copyright © 2010-2015 ARM.All rights reserved.