2.13 Android ターゲットへの hello-neon アプリケーションのロード

Android ターゲットへの hello-neon アプリケーションのロード方法を説明します。

手順

  1. Eclipse を起動します。
  2. ターゲットを起動します。
  3. 新しい Android プロジェクトを作成します。
    1. [File] > [New] > [Project...]を選択します。
    2. [Android]グループを展開し、[Android Project]を選択します。
    3. [Next]をクリックします。
    4. 適切なプロジェクト名を入力します。例えば、「HelloNeon」と指定します。
    5. [既存のソースからプロジェクトを作成]を選択します。
    6. [参照...]をクリックして、hello-neon フォルダを検索します。
    7. [Next]をクリックします。
    8. 必要なビルドターゲットを選択します。例えば、[Android 2.2]を選択します。
    9. [Finish]をクリックします。
  4. アプリケーションが、デバッグ情報とともにビルドされることを確認してください。これは以下の方法で行います。
    1. AndroidManifest.xml ファイルを開きます。
    2. [Application]タブをクリックします。
    3. [Debuggable]フィールドで、[true]を選択します。
    4. 変更を保存してファイルを閉じます。
  5. Android NDK に付属のスクリプトを使用して、hello-neon ソースファイルをデバッグ情報付きでビルドします。このチュートリアルでは、NDK リビジョン 6b を使用します。例えば、
    ./ndk-build -C samples/hello-neon NDK_TOOLCHAIN=arm-linux-androideabi-4.4.3 NDK_DEBUG=1
  6. Android プロジェクトを選択し、HelloNeon.apk をビルドします。
  7. 新しい AVD(Android Virtual Device)を作成し、エミュレータを起動します。
  8. [Run]メニューから[Debug Configurations...]を選択します。
  9. コンフィギュレーションツリーから[DS-5 Debugger]を選択し、[New]をクリックして新しいコンフィギュレーションを作成します。または、既存の DS-5 デバッガコンフィギュレーションを選択し、ツールバーで[Duplicate]をクリックします。
  10. [Name]フィールドに、新しいコンフィギュレーションの適切な名前を入力します。例えば、「HelloNeon」と指定します。
  11. [Connection]タブをクリックしてターゲットと接続オプションを表示します。
  12. [Select target]パネルで、以下のように操作します。
    1. [Android - Generic platform(Android - 汎用プラットフォーム)]を選択します。
    2. デバッグ操作の[Download and debug an Android application(Android アプリケーションのダウンロードとデバッグ)]を選択します。
    3. [接続]フィールドでエミュレータを選択します。
    図 2-16 Android アプリケーションの一般的な[接続]タブ設定
    Android アプリケーションの一般的な[接続]タブ設定

  13. [ファイル] タブで[プロジェクト]ディレクトリフィールドの[ワークスペース...]をクリックして、hello-neon ディレクトリを選択します。これにより、その他のフィールドに値が入力されます。
    図 2-17 Android アプリケーションの一般的な[ファイル]タブ設定
    Android アプリケーションの一般的な[ファイル]タブ設定

  14. [実行]コントロールパネルの[デバッガ]タブをクリックし、[接続のみ]を選択します。
  15. [パス]パネルで、[ワークスペース...]をクリックして、hello-neon ディレクトリを選択します。
    図 2-18 Android アプリケーションの一般的な[デバッガ]タブ設定
    Android アプリケーションの一般的な[デバッガ]タブ設定

  16. [Debug]をクリックしてターゲットに接続します。
  17. デバッグには、DS-5 デバッグパースペクティブが必要です。[Confirm Perspective Switch]ダイアログボックスが表示された場合は、[Yes]をクリックしてパースペクティブを切り替えます。
  18. 必要に応じてブレークポイントを設定、実行、ステップ実行をして、モジュールをデバッグします。

NDK が gdbserver をネイティブライブラリに接続する前にアプリケーションが存在する場合は、Java ネイティブライブラリを起動する前にディレイを追加しなければならないことがあります。
関連する作業
2.12  DS-5 を使用するための Android ツールの設定
2.14 Android ターゲット上で既に実行されているアプリケーションへの接続
関連情報
DS-5 技術情報記事
Eclipse
Cygwin
Android Developers
非機密扱いPDF file icon PDF 版ARM DUI0478TJ
Copyright © 2010-2014 ARM.All rights reserved.