Configuring the C/C++ build behavior

A build is the process of compiling and linking source files to generate an output file. A build can be applied to either a specific set of projects or the entire workspace. It is not possible to build an individual file or sub-folder.

Eclipse provides an incremental build that applies the selected build configuration to resources that have changed since the last build. Another type of build is the Clean build that applies the selected build configuration to all resources, discarding any previous build states.

Automatic

This is an incremental build that operates over the entire workspace and can run automatically when a resource is saved. This setting must be enabled for each project by selecting Build on resource save (Auto build) in the Behaviour tab. By default, this behavior is not selected for any project.

Figure 28. Workbench build behavior

Workbench build behavior

You must also ensure that Build Automatically is selected from the Project menu. By default, this menu option is selected.

Manual

This is an incremental build that operates over the entire workspace on projects with Build (Incremental build) selected. By default, this behavior is selected for all projects.

You can run an incremental build by selecting Build All or Build Project from the Project menu.

Note

Manual builds do not save before running so you must save all related files before selecting this option! To save automatically before building, you can change your default settings by selecting Preferences... → General → Workspace from the Window menu.

Clean

This option discards any previous build states including object files and images from the selected projects. The next automatic or manual build after a clean, applies the selected build configuration to all resources.

You can run a clean build on either the entire workspace or specific projects by selecting Clean... from the Project menu. You must also ensure that Clean is selected in the C/C++ Build → Behaviour tab of the Preferences dialog box. By default, this behavior is selected for all projects.

Build order is a feature where inter-project dependencies are created and a specific build order is defined. For example, an image might require several object files to be built in a specific order. To do this, you must split your object files into separate smaller projects, reference them within a larger project to ensure they are built before the larger project. Build order can also be applied to the referenced projects.

Show/hideSee also

Copyright © 2010, 2011 ARM. All rights reserved.ARM DUI 0480F
Non-ConfidentialID071411