ソースコードの編集

ソースコードの編集には Eclipse に備わっているエディタを使用できますが、外部エディタも使用できます。外部エディタで作業する場合は、Eclipse の表示を最新の内容に同期させるために表示を更新する必要があります。それには、[Project Explorer]ビューで更新されたプロジェクト、サブフルダ、またはファイルをクリックして、[File]メニューの[Refresh]を選択します。自動的に更新されるようにするには、[Preferences]ダイアログボックスで、[General] → [Workspace] → [Refresh automatically]を選択します。

Eclipse 内でファイルを開くと、そのファイル名を持つ新しいエディタタブが表示されます。ファイルが編集されるとタブ名にアスタリスク(*)が示され、未保存の変更があることを示します。

複数のエディタタブが開いているときは、左右に並べてタイル表示できます。タブをクリックして別のエディタの輪郭線までドラッグしてください。

エディタタブの左余白に表示される縦のバーには、アクティブなファイルに関係する各種マーカーが表示されます。

Show/hideナビゲーション

Eclipse 内の特定のリソースに移動する方法はいくつかあります。[Project Explorer]ビューでは、リソースツリーをたどってファイルをダブルクリッすることによって、リソースを開くことができます。もう一つの方法は、キーボードショートカットまたは[Navigate]メニューのオプションを使用することです。

Show/hide検索

Eclipse でファイル内の情報やコードを検索するには、[Search]メニューのオプションを使用できます。[Search]ダイアログボックスでは、テキスト検索、テキストパターン検索、絞り込むためのフィルタなど使用でき、カスタマイズ可能です。このダイアログボックスはワークベンチのメインツールバーからも開くことができます。

Show/hideコンテンツアシスト

C/C++ エディタ、ARM® アセンブラエディタ、および DS-5 デバッガコマンドビューには、カーソル位置で選択された項目のオートコンプリートを行うコンテンツアシスタンス機能が備わっています。キーボードショートカットとして Ctrl+ スペースを押すと、小さなダイアログボックスが表示され、有効な選択肢が表示されます。キーボードショートカットを押す前に、入力の一部として数文字を入力しておくと、選択肢のリストを短くできます。矢印キーを使てリスト内を移動して必要な項目を選択したら、Enter キーを押して挿入します。

Show/hideブックマーク

ブックマークはファイル内の場所、またはファイル全体に付けるマークであり、その場所に簡単に戻れるようにします。ブックマークを作成するは、マークを付けるファイルまたはコード行を選択してから、[Edit]メニューの[Add Bookmark]を選択します。[Bookmarks]ビューにはユーザーが定義したブックマークが表示されます。これは、メインメニューで[Window] → [Show View] → [Bookmarks]を選択すると表示されます。[Bookmarks]ビューがビューのリストに含まれていない場合は、[Others...]を選択すると他のビューのリストも表示されます。

ブックマークを削除するには、[Bookmarks]ビューを開いて、削除するブックマークをクリックし、[Edit]メニューの[Delete]を選択します。

Show/hide関連項目

Copyright © 2010, 2011 ARM. All rights reserved.ARM DUI 0480GJ
Non-ConfidentialID111511