C/C++ ビルド動作の設定

ビルドはソースファイルをコンパイルしてリンクした出力ファイルを生成する処理です。ビルドは特定のプロジェクトの組み合わせ、またはワースペース全体に対して適用できます。個々のファイルやサブフォルダのビルドはできません。

Eclipse では、最後のビルド以降に変更されたリソースに選択されたビルドコンフィギュレーションを適用して、増分ビルドができます。ビルドのう一つの種類として、選択されたビルドコンフィギュレーションをすべてのリソースに適用して、以前のビルドをすべて捨て去るクリーンビルドがあります。

自動

これはリソースが保存されたときに自動的に実行され、ワークスペース全体に適用される増分ビルドです。この設定は個々のプロジェクトで有効なっている必要があり、[Behaviour]タブで[Build on resource save (Auto build)]を選択して設定します。デフォルトでは、この動作はどのプロジェクトにも選択されていません。

Figure 27. ワークベンチのビルド動作

ワークベンチのビルド動作

[Build Automatically][Project]メニューでも選択されていることを確認する必要があります。このメニューオプションはデフォルトで選択されています。

手動

これはワークスペース全体で[Build (Incremental build)]が選択されているプロジェクトに適用される増分ビルドです。デフォルトでは、この動作はすべてのプロジェクトで選択されています。

増分ビルドは、[Project]メニューの[Build All]または[Build Project]を選択することによって実行できます。

Note

手動ビルドでは実行の前に保存されません。したがって、このオプションを選択する前に関係するすべてのファイルを保存する必要があります。ルドの前に自動的に保存されるようにするには、デフォルト設定を変更します。それには、[Window]メニューの[Preferences...] → [General] → [Workspace]を選択します。

クリーン

このオプションは選択されているプロジェクトの以前のビルドをすべて(オブジェクトファイルとイメージファイルを含めて)捨て去ります。クーンビルドの次の自動ビルドや手動ビルドでは、選択されたビルドコンフィギュレーションがすべてのリソースに適用されます。

クリーンビルドは、[Project]メニューの[Clean...]を選択することによって、ワークスペース全体または特定のプロジェクトに対して実行できます。[Preferences]ダイアログボックスの[C/C++ Build] → [Behaviour]タブで[Clean]が選択されていることを確認する必要があります。デフォルトでは、この動作はすべてのプロジェクトで選択されています。

ビルド順序の処理では、プロジェクト間の依存関係が作成されビルド順序が定義されます。例えば、複数のオブジェクトファイルが特定の順序でルドされる必要のあるイメージがあります。それには、オブジェクトファイルを複数の小さなプロジェクトに小分けし、大きなプロジェクトかそれらを参照することによって、それらが大きなプロジェクトより前にビルドされるようにできます。参照されているプロジェクトにはビルド順序を適用できます。

Show/hide関連項目

Copyright © 2010, 2011 ARM. All rights reserved.ARM DUI 0480GJ
Non-ConfidentialID111511