パースペクティブとビュー

ワークベンチのメインウィンドウには複数のパースペクティブがあり、個々のパースペクティブには各種のビューがあります。

Show/hideパースペクティブ

パースペクティブは[Window]メニューのオプションを使って開きカスタマイズできます。パースペクティブツールバーを使うこともできます。 デフォルトでは、パースペクティブは同じウィンドウ内で開きますが、[Preferences]ダイアログボックスでこのデフォルト設定を変更できます。

Eclipse for DS-5 では C/C++ パースペクティブと DS-5 デバッグパースペクティブが主体になっています。 パースペクティブを変更するにはパースペクティブツールバーを使うか、メインメニューから[Window] → [Open perspective]を選択します。

Figure 11. ツールバーメニューを使ったパースペクティブの変更

ツールバーメニューを使ったパースペクティブの変更

Show/hideビュー

ビューは Eclipse 内で表示される小さなコンポーネントで、リソースへのナビゲーションや特定プロパティの表示に使用されます。 エディタはソースファイルの表示と編集ができる特殊なビューです。

ビューはドラッグアンドドロップによって移動したりドッキングしたりできます。 ビューのタブをダブルクリックすると、そのビューの最大化と元のサイズに戻すオプションの間で切り替えることができます。同じオプションがツールバーアイコンにもあります。 パースペクティブ内のすべてのビューを初期設定と初期レイアウトにリセットするには、[Window]メニューの[Reset Perspective...]をクリックします。

C/C++ アプリケーションのビルドとデバッグでは以下のビューが役立ちます。

エディタ

エディタは特定のファイルタイプに関連付けられているので、編集可能なファイルを[Project Explorer]ビューで開くと関連付けられているエディタのビューが自動的に開きます。

標準ビュー
Console

プロジェクトをビルドするときに出力メッセージが表示されるビューです。アプリケーションの実行時とデバッグ時にも実行メッセージが表示さます。

Outline

アクティブファイル内の C/C++ 要素を構造化したリストにして表示します。 要素をクリックするとアクティブファイル内のその要素の場所にエデタのフォーカスが移動します。

Problems

ビルド中に発生したエラーメッセージを表示します。 エラーメッセージを選択すると、関連するファイルが開きその問題の原因となったコード行にフォーカスが移動します。

Progress

タスクの進行中に進行状況を示すメータを表示します。

Project Explorer

C/C++ プロジェクトファイルに関係するリソースの階層ビューを表示します。 リソースを右クリックすると関連タスクのコンテキストメニューが表示されます。

Properties

選択された項目の名前と値を表示します。 例えば、ファイルの最終変更日付などが表示されます。

ヘルプビュー
Help Contents

インストールされているマニュアルを表示します。

Dynamic Help

選択された機能に関するダイナミックヘルプを表示します。

Cheat Sheets

特定タスクの手順を順を追って説明します。 表示メニューを使ってチートシートのリストにアクセスできます。

DS-5 デバッガビュー
App Console

ARM® C ライブラリ内でセミホスティングの実装によって提供される I/O 機能を使用できます。

ARM Asm Info

ARM® または Thumb® の命令やディレクティブの詳細情報を表示できます。

Breakpoints

すべてのブレークポイントと対応するソースコードまたはターゲットメモリ内の場所を表示します。 このビューではブレークポイントの追加、編集、削除、オンオフができます。

Commands

デバッガのスクリプト機能へのアクセスを提供します。 デバッガの動作のほとんどがここにエコーされます。DS-5 デバッガのコマンドを実行するともできます。

Debug Control

デバッグの接続状態、プロセッサ、スレッド、および該当する場合はスタックフレームを表示する階層ツリー構造が含まれています。

Disassembly

逆アセンブリされたコードを表示します。

Expressions

式の表示と編集ができます。

Functions

ロードされたすべてのイメージについて、関数シンボルと関連付けられている ELF データを表示できます。

History

実行されたデバッガコマンドの履歴ログです。

Memory

メモリ内容の表示と編集ができます。

Modules

共有ライブラリやロードされているオペレーティングシステム(OS)モジュールを表示できます。

Registers

スタックフレームに関連付けられているレジスタの表示と編集ができます。 アプリケーションが停止すると、変更された値が強調表示されます。

Screen

メモリブロックをグラフィカルイメージとして表示できます。 フレームバッファがその例です。

Scripts

スクリプトファイルにアクセスして実行および編集できます。

Target

デバッガに現在接続されているターゲットデバイスの機能の一覧を表示します。

Trace

デバッグエージェントからキャプチャしたトレース情報を表示します。

Variables

選択したスタックフレームに関連付けられている変数の表示と編集ができます。

リモートシステムビュー
Remote Scratchpad

後で利用できるように、ローカルリソースをコピーして張り付けたり、ドラッグしてドロップしたりできる電子雑記帳です。

Remote Systems

ホストワークステーションとリモートターゲットへの接続を作成して、そこにあるリソースにアクセスできます。

Terminals

外部アプリケーションを起動しないで、ターゲットに直接シェルコマンドを入力できます。

パースペクティブには他のビューも追加できますが、パースペクティブによっては使用できないビューもあります。 ビューをパースペクティブに追加するには

  1. 適切なパースペクティブで作業していることを確認します。

  2. [Window] → [Show View] → [Other...]を選択して[Show View]ダイアログボックスを開きます。

  3. 必要なビューを選択します。

  4. [OK]をクリックします。

ここに記載されていないビューについては、ダイナミックヘルプを参照してください。

Show/hideトリムバー

最小化されたビューは現在のパースペクティブの端にあるトリムバーに表示されます。 デフォルトでは、パースペクティブの右余白にトリムバーが表示されますが、ドラッグアンドドロップで別の場所に移動できます。 トリムバーでは、ビューアイコンをダブルクリックすると元の表示に戻ります。元のサイズに戻すアイコンをクリックして最小化されているすべてのビューを元のサイズに戻すこともできます。

Figure 12. 最小化されたビューのトリムバーでの表示

最小化されたビューのトリムバーでの表示

Show/hideファーストビューバー

ファーストビューは即座にアクセスできる非表示のビューです。これは現在のパースペクティブで場所を取らないようにするために用意されています。 ファーストビューを選択すると現在のパースペクティブに表示されますが、フォーカスを失うとまた非表示になります。 デフォルトでは、ファーストビューバーは現在のパースペクティブの下余白に表示されますが、ドラッグアンドドロップで別の場所に移動できます。

Figure 13. ファーストビューバー

ファーストビューバー

ビューをファーストビューバーに追加するには、ビュータブを右クリックして、コンテキストメニューから[Fast View]を選択します。

Show/hide関連項目

Copyright © 2010-2012 ARM. All rights reserved.ARM DUI 0480IJ
Non-ConfidentialID051512