Editing source code

You can use the editors provided with Eclipse to edit your source code or you can use an external editor. If you work with an external editor you must refresh Eclipse to synchronize the views with the latest updates. To do this, in the Project Explorer view, you can click on the updated project, sub-folder, or file and select Refresh from the File menu. Alternatively you can enable the automatic refresh option by selecting General → Workspace → Refresh automatically in the Preferences dialog box.

When you open a file in Eclipse, a new editor tab appears with the name of the file. An edited file displays an asterisk (*) in the tab name to show that it has unsaved changes.

When you have two or more editor tabs open, you can tile them for side-by-side viewing by clicking on a tab and dragging it over an editor border.

In the left-hand margin of the editor tab you can find a vertical bar that displays markers relating to the active file.

Show/hideNavigating

There are several ways to navigate to a specific resource within Eclipse. You can use the Project Explorer view to open a resource by browsing through the resource tree and double-clicking on a file. An alternative is to use the keyboard shortcuts or use the options from the Navigate menu.

Show/hideSearching

To locate information or specific code contained within one or more files in Eclipse, you can use the options from the Search menu. Textual searching with pattern matching and filters to refine the search fields are provided in a customizable Search dialog box. You can also open this dialog box from the main workbench toolbar.

Show/hideContent assist

The C/C++ editor, ARM® assembler editor, and the DS-5 Debugger Commands view provide content assistance at the cursor position to auto-complete the selected item. Using the Ctrl+Space keyboard shortcut produces a small dialog box with a list of valid options to choose from. You can shorten the list by partially typing a few characters before using the keyboard shortcut. From the list you can use the Arrow Keys to select the required item and then press the Enter key to insert it.

Show/hideBookmarks

Bookmarks can be used to mark a specific position in a file or mark an entire file so that you can return to it quickly. To create a bookmark, select a file or line of code that you want to mark and select Add Bookmark from the Edit menu. The Bookmarks view displays all the user defined bookmarks and can be accessed by selecting Window → Show View → Bookmarks from the main menu. If the Bookmarks view is not listed then select Others... for an extended list.

To delete a bookmark, open the Bookmarks view, click on the bookmark that you want to delete and select Delete from the Edit menu.

Show/hideSee also

Copyright © 2010-2012 ARM. All rights reserved.ARM DUI 0480K
Non-ConfidentialID071912