1.12 Perspectives and views

The main workbench window contains one or more perspectives and each perspective contains one or more views.

Perspectives

Perspectives can be opened and customized using the options from the Window menu or you can use the Perspective toolbar. By default, a perspective opens in the same window, however, you can change the default settings in the Preferences dialog box.
Eclipse for DS-5 focuses on the C/C++ perspective and the DS-5 Debug perspective. You can change perspective by using the Perspective toolbar or you can select Window > Open Perspective from the main menu.
Figure 1-11 Changing perspective using the toolbar menu
Changing perspective using the toolbar menu

Views

A view is a small visual component within Eclipse to navigate through resources or to display specific properties. An editor is a special type of view that enables viewing and editing source files.
Views can be moved or docked as applicable by dragging and dropping them into position. Double-clicking on a view tab toggles the maximize/restore options for that view or you can use the relevant toolbar icons.

Tip

HandTo reset all the views in a perspective to the initial settings and layout, click Reset Perspective... in the Window menu.
The following views are useful when building and debugging C/C++ applications:
Editors
Editors are associated with specific file types and open the related editor view automatically when you open an editable file from the Project Explorer view.
General views
Console
Displays output messages when building projects and also execution messages when running or debugging an application.
Outline
Displays a structured list of C/C++ elements in the active file. Clicking on an element changes the editor focus to the position of that element in the active file.
Problems
Displays error messages encountered during a build. Selecting an error message opens the associated file and moves the focus to the line causing the problem.
Progress
Displays the progress meter when a task is in progress.
Project Explorer
Provides a hierarchical view of resources relevant to C/C++ project files. Right-clicking on a resource produces a context menu for specific tasks.
Properties
Displays names and values for the selected item. For example, the last modified time/date for a file.
Help views
Help Contents
Displays the installed documentation.
Dynamic Help
Displays dynamic help for the selected feature.
Cheat Sheets
Displays step by step instructions to help you complete a specific task. Use the view menu to access the list of cheat sheets.
DS-5 Debugger views
App Console
Enables you to interact with the I/O capabilities provided by the semihosting implementation in the ARM® C libraries.
ARM Asm Info
Enables you to view more information on an ARM or Thumb® instruction or directive.
Breakpoints
Displays all the breakpoints and the respective locations in source code or target memory. Using this view you can add, edit, delete, enable, or disable breakpoints.
Commands
Provides access to the scripting functionality of the debugger. Most debugger actions are echoed here and you can also execute DS-5 Debugger commands.
Debug Control
Contains a tree hierarchy showing debug connection states, processors, threads and stack frames as applicable.
Disassembly
Displays disassembled code.
Expressions
Enables you to view and edit expressions.
Functions
Enables you to view ELF data associated with function symbols for all loaded images.
History
Provides a historical log of all the executed debugger commands.
Memory
Enables you to view and edit the contents of memory.
Modules
Enables you to view shared libraries or loaded Operating System (OS) modules.
Registers
Enables you to view and edit registers associated with the selected stack frame. When your application stops, modified values are highlighted.
Screen
Enables you to display a block of memory as a graphical image. For example, a frame buffer.
Scripts
Provides access to run and edit script files.
Target
Displays a list of capabilities for the target device that is currently connected to the debugger.
Trace
Displays the captured trace information from the debug agent.
Variables
Enables you to view and edit variables associated with the selected stack frame.
Remote Systems views
Remote Scratchpad
Enables you to copy and paste or drag and drop local resources to an electronic clipboard for use at a later point in time.
Remote Systems
Enables you to create connections and access resources on the host workstation and remote targets.
Terminals
Enables you to enter shell commands directly on the target without launching any external application.
Other views can be added to a perspective but they might not be compatible with all perspectives. To add a view to a perspective:
  1. Ensure that you are in the relevant perspective.
  2. Select Window > Show View > Other... to open the Show View dialog box.
  3. Select the required view.
  4. Click OK.
For more information on the other views not listed here, use the dynamic help.

Trim bar

Minimized views are placed in the trim bar at the edge of the current perspective. By default, the trim bar is on the right-hand margin of the perspective but you can drag and drop it to another location if you prefer. In the trim bar, you can double-click on a view to restore it or click on the restore icon to restore all the minimized views.
Figure 1-12 Minimized views in the trim area
Minimized views in the trim area

Non-ConfidentialPDF file icon PDF versionARM DUI0480Q
Copyright © 2010-2015 ARM. All rights reserved.