6.1 Compatibility of ARM Compiler v5.03 with legacy objects and libraries

Backwards compatibility of objects and libraries built with RVCT 3.0 and earlier is supported provided they have not been built with --apcs /adsabi.

Given these restrictions, ARM strongly recommends that you rebuild your entire project, including any user, or third-party supplied libraries, with ARM Compiler v5.03. This is to avoid any potential incompatibilities, and to take full advantage of the improved optimization, enhancements, and new features provided by ARM Compiler v5.03.

Non-ConfidentialPDF file icon PDF versionARM DUI0530M
Copyright © 2010-2016 ARM Limited or its affiliates. All rights reserved.