Cycle Model Studio
Windows Visual C++ SystemC Integration Application Note

Copyright © 2016 ARM Limited. All rights reserved.

Release Information
The following changes have been made to this document.

Change History

<table>
<thead>
<tr>
<th>Date</th>
<th>Issue</th>
<th>Confidentiality</th>
<th>Change</th>
</tr>
</thead>
<tbody>
<tr>
<td>November 2016</td>
<td>A</td>
<td>Non-Confidential</td>
<td>Restamp release with 9.0.0</td>
</tr>
</tbody>
</table>

Non-Confidential Proprietary Notice

This document is protected by copyright and other related rights and the practice or implementation of the information contained in this document may be protected by one or more patents or pending patent applications. No part of this document may be reproduced in any form by any means without the express prior written permission of ARM Limited ("ARM"). No license, express or implied, by estoppel or otherwise to any intellectual property rights is granted by this document specifically stated.

Your access to the information in this document is conditional upon your acceptance that you will not use or permit others to use the information for the purposes of determining whether implementations infringe any patents.

THIS DOCUMENT IS PROVIDED “AS IS”. ARM PROVIDES NO REPRESENTATIONS AND NO WARRANTIES, EXPRESS, IMPLIED OR STATUTORY, INCLUDING, WITHOUT LIMITATION, THE IMPLIED WARRANTIES OF MERCHANTABILITY, SATISFACTORY QUALITY, NON-INFRINGEMENT OR FITNESS FOR A PARTICULAR PURPOSE WITH RESPECT TO THE DOCUMENT. For the avoidance of doubt, ARM makes no representation with respect to, and has undertaken no analysis to identify or understand the scope and content of, third party patents, copyrights, trade secrets, or other rights.

This document may include technical inaccuracies or typographical errors.

This document may be translated into other languages for convenience, and you agree that if there is any conflict between the English version of this document and any translation, the terms of the English version shall prevail.

TO THE EXTENT NOT PROHIBITED BY LAW, IN NO EVENT WILL ARM BE LIABLE FOR ANY DAMAGES, INCLUDING WITHOUT LIMITATION ANY DIRECT, INDIRECT, SPECIAL, INCIDENTAL, PUNITIVE, OR CONSEQUENTIAL DAMAGES, HOWEVER CAUSED AND REGARDLESS OF THE THEORY OF LIABILITY, ARISING OUT OF ANY USE OF THIS DOCUMENT, EVEN IF ARM HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

This document consists solely of commercial items. You shall be responsible for ensuring that any use, duplication or disclosure of this document complies fully with any relevant export laws and regulations to assure that this document or any portion thereof is not exported, directly or indirectly, in violation of such export laws. Use of the word “partner” in reference to ARM’s customers is not intended to create or refer to any partnership relationship with any other company. ARM may make changes to this document at any time and without notice.

If any of the provisions contained in these terms conflict with any of the provisions of any signed written agreement specifically covering this document with ARM, then the signed written agreement prevails over and supersedes the conflicting provisions of these terms.

Words and logos marked with ® or ™ are registered trademarks or trademarks of ARM Limited or its affiliates in the EU and/or elsewhere. All rights reserved. Other brands and names mentioned in this document may be the trademarks of their respective owners. You must follow the ARM trademark usage guidelines http://www.arm.com/about/trademarks/guidelines/index.php.

Copyright © ARM Limited or its affiliates. All rights reserved.
110 Fulbourn Road, Cambridge, England CB1 9NJ.

In this document, where the term ARM is used to refer to the company it means “ARM or any of its subsidiaries as appropriate”.

ARM DUI 1047A Copyright © 2016 ARM Limited. All Rights Reserved
Non-Confidential
Confidentiality Status

This document is Non-Confidential. The right to use, copy and disclose this document may be subject to license restrictions in accordance with the terms of the agreement entered into by ARM and the party that ARM delivered this document to.

Product Status

The information in this document is final, that is for a developed product.

Web Address

http://www.arm.com
Abstract

This application note describes how to integrate a Cycle Model with the Microsoft Visual C++ .NET Windows environment and Accellera SystemC. This process includes setting up the Cycle Model Studio Windows environment, compiling the Cycle Model on Linux, setting up the SystemC Windows environment, and integrating with Visual C++.

Integration Process

The basic integration procedure includes the following steps:

1. Setting up the Cycle Model Studio environment on Windows.
2. Setting up the SystemC environment on Windows.

Note that this procedure has been verified on Windows XP.

Before you begin, make sure that your Cycle Model Studio environment is set up correctly on Linux, and that you can compile a Cycle Model for use on Linux.

Step 1 – Cycle Model Studio Windows Environment Setup

First, you must have Read access to an ARM Cycle Model Studio release directory on Windows. You can mount the Cycle Model Studio release directory on to your PC, copy the required directories/files to your PC, or install Cycle Model Studio software on your Windows machine (see the Cycle Model Studio Installation Guide). If you mount or copy the release data from Linux, make sure the release installation included the Windows data. If you install the Cycle Model Studio Windows release, make sure it matches the release version installed on Linux.

At a minimum, you need the following directories from CARBON_HOME:

- include
- lib
- makefiles
- Win
- systemc (may be needed if SystemC is not already installed)

In addition, you must set the following environment variables appropriately (see the Cycle Model Studio Installation Guide for additional details):

- CARBON_HOME
- ARMLMD_LICENSE_FILE (or LM_LICENSE_FILE)

Set these environment variables in Windows by selecting:

Start > Control Panel > System > Advanced > Environment Variables
The following dialog displays.

Lastly, add the following to your Windows PATH environment variable, based on your CARBON_HOME variable.

%CARBON_HOME%\Win\lib; %CARBON_HOME%\Win\lib\winx\shared

Depending on your environment, you may need to explicitly expand %CARBON_HOME%.

Note: For UNIX users, on Windows, the %VARIABLE_NAME% notation is identical to shell variable accessing via $VARIABLE_NAME.

Step 2 – SystemC Windows Environment Setup

The SystemC 2.2 distribution file is available at %CARBON_HOME%\systemc\systemc-dist.tgz. Unpack the “systemc-dist.tgz” with WinZip or other tool at an appropriate location (for example, C:\Program Files\SystemC\SystemC_2_2). Create a Windows environment variable called SYSTEMC_HOME that points at the SystemC installation directory. Open the %SYSTEMC_HOME%\INSTALL file with a text editor for details on SystemC installation instructions.
Go to %SYSTEMC_HOME%\msvc71\SystemC, and open the SystemC Project file, “SystemC.vcproj” with Visual Studio. This can be accomplished by double clicking on “SystemC.vcproj”.

1. After opening the project, modify the project to use the /MD option for the Release configuration, and the /MDd option for the Debug configuration (rather than the /ML (or /MLd) compiler options) so that it uses the multi-threaded DLL version of the C runtime libraries.

    - From the Project menu, choose Properties. Choose “C/C++” -> “Code Generation” and set the “Runtime Library” field to “Multi-threaded Debug DLL (/MDd)” for the Configuration: Debug, and to “Multi-threaded DLL (/MD)” for the Configuration: Release.

2. Build debug and release configurations:

    - To build the Release configuration:
      i. Set “Solution Configuration” to “Release”.
      ii. Select Build -> Build Solution.

    - To build Debug configuration:
      i. Set “Solution Configuration” to “Debug”.
      ii. Select Build -> Build Solution.

Step 3 – Creating the Cycle Model

To compile a Cycle Model for Windows on a Linux machine, specify the .lib file extension for the Cycle Model name (in the format lib<design>.lib) using the -o Cycle Model Compiler option. Note that you need to replace <design> with the name of the design.
Using Cycle Model Studio, specify the file name in the Basic Options section of the Compiler Properties, as shown below:

Using the Cycle Model Compiler (cbuild) command line, enter:

```
cbuild -o lib<design>.lib ...
```

instead of `-o lib<design>.a`, which generates a Cycle Model for UNIX.

The Cycle Model Studio or the Cycle Model compiler outputs a number of files, including the following, which are required for compiling/running the executable on Windows:

- `lib<design>.lib` – Windows static object library
- `lib<design>.h` – include file for interfacing to the Cycle Model
- `lib<design>.symtab.db` – Cycle Model database with information about all internal signals
- `lib<design>.io.db` – Cycle Model database with only a subset of the signals—only the IOs and additional signals marked as observable or depositable

Additionally, for use with SystemC, the following files generated by the Cycle Model Studio (or by `systemCWrapper`) are needed:

- `lib<design>.systemc.cpp` – SystemC wrapper file
- `lib<design>.systemc.h` – SystemC header file

All files listed above must be copied to (or be accessible to) your Windows environment.

**Step 4 – Visual C++ Integration**

To integrate the Cycle Model, you must either create a new Visual C++ project or make changes to your existing project. The following are the steps to open and set up a new project:

   - Select File -> New Project and create a project with the following settings:
2. Add C++/SystemC files to the project, etc. This can be accomplished by dragging and dropping the files into the Visual Studio “Solution Explorer”. For the Cycle Model, the following files must be added (including the SystemC wrapper files):
   - Source Files: lib<design>.systemc.cpp
   - Header Files: lib<design>.h, lib<design>.systemc.h

3. Open the Project Property Page (Project -> Properties), and set the following properties:
   - Set “Configuration:” to “All Configurations”.
   - From the “Configuration Properties” tab, select the “Debugging” properties and set “Working Directory” to the directory containing the Cycle Model DB file(s) (lib<design>.symtab.db and/or lib<design>.io.db).

Note: The default location for the Cycle Model DB file is the current directory. The DB file is embedded in the Cycle Model by default when it is compiled (see the ARM Cycle Model Compiler User Manual, ARM DUI 0957, for information on the compiler options -embedIODB and -noFullDB). Additionally, the carbonSetFilePath() C-API function can be used in the Cycle Model Wrapper to specify other locations to find the DB file.
From the “C/C++” tab,

i. Select the “General” properties and set “Additional Include Directories” to:
   "$(CARBON_HOME)\include";"$(SYSTEMC_HOME)\src".

   **Note:** "$(SYSTEMC_HOME)\src" is required by SystemC.

ii. Set “Detect 64-bit Portability Issues” to:
   No

   **Note:** This is required by SystemC.
iii. Select the “Language” properties and set “Enable Run-Time Type Info” to:

\textbf{Yes (/GR)}

\textbf{Note:} This is required by SystemC.

iv. Select the “Command Line” properties and in the “Additional Options:” box add:

\texttt{/vmg}

\textbf{Note:} This is required by SystemC. Failure to do this can cause your program to crash.

- From the Linker tab, select the “Input” properties and in the “Additional Dependencies” box add:

\texttt{lib<design>.lib libcarbon5.lib ffwAPIexp.lib SystemC.lib libgcc.lib}

\textbf{Note:} “SystemC.lib” is required by SystemC.

- Click \texttt{Apply}.

- Set “Configuration:” to “Release”.
  - From the “C/C++” tab, select the “Code Generation” properties and set “Runtime Library” to “Multi-threaded DLL (/MD)”.
  - From the Linker tab, select the “General” properties and in the “Additional Library Directories” box add:

\begin{verbatim}
"$(SYSTEMC_HOME)\msvc71\SystemC\Release";"$(CARBON_HOME)\Win\lib";"$(CARBON_HOME)\Win\Lib\win\x\shared";
"$(CARBON_HOME)\Win\x\lib\gcc\i386-mingw32msvc\3.4.5-a";
<directory containing the Cycle Model, the libdesign.lib file>
\end{verbatim}

  - Click \texttt{Apply}.

- Set “Configuration:” to “Debug”.
  - From the “C/C++” tab, select the “Code Generation” properties and set “Runtime Library” to “Multi-threaded Debug DLL (/MDd)”.
  - From the Linker tab, select the “General” properties and in the “Additional Library Directories” box add:

\begin{verbatim}
"$(SYSTEMC_HOME)\msvc71\SystemC\Debug";"$(CARBON_HOME)\Win\lib";"$(CARBON_HOME)\Win\Lib\win\x\shared";
"$(CARBON_HOME)\Win\x\lib\gcc\i386-mingw32msvc\3.4.5-a";
<directory containing the Cycle Model, the libdesign.lib file>
\end{verbatim}

  - Click \texttt{OK}.

4. Build the Project.

  - Set the configuration to either “Debug” or “Release”.
5. Run the Simulation.
   - Set the configuration to either “Debug” or “Release”.
   - Select Debug -> Start.


If the simulation reports an exception error at the beginning, there may be a problem finding the ARM license or finding the Cycle Model database file. To determine the cause, perform the following steps:

   - Set a breakpoint on the exit function:
     - Open the New Breakpoint window by selecting Debug -> New Breakpoint (or Ctrl+B).
     - In the Function field, type “exit”.
     - Click OK.

   - Start the simulation by selecting Debug -> Start (or F5).
   - Examine the error message(s) displayed in the Command Prompt window that was open when the simulation started.

If it is a license issue, you may see the following error message:

```
Error: Carbon: License checkout failed - 'Checkout of crbn_vsp
failed: No VENDOR_STRING match for SIG=Carbon - checkout failed:
```

In this case, examine the ARMLMD_LICENSE_FILE environment variable to verify that it is set to a valid license.

If it cannot find the Cycle Model database file, you may see the following error message:
Error: Carbon: Error opening file libcounter.symtab.db: No such file or directory or path is not readable. Current dir: C: \Visual Studio Projects\counter -- Search path: ./
In file: c:\visual studio projects\counter\libcounter.systemc.h:295

In this case, verify that the “Working Directory” (Projects -> Property -> Configuration Properties -> Debugging -> Working Directory) is pointing to the directory containing the Cycle Model database file.

7. Configuration for Simulation Portability.

When the simulation starts, the Cycle Model loads certain DLLs. If the simulation will be run on a machine without access to the Cycle Model Studio installation, you will need to copy those DLLs to one of the following locations: in the same directory as the .exe file that runs the simulation, in the process’s current directory, or in a directory listed in the PATH environment variable. The DLLs that are affected are:

%CARBON_HOME%\Win\lib\ffwAPI.dll
%CARBON_HOME%\Win\lib\winx\shared\libcarbon5.dll
%CARBON_HOME%\Win\lib\winx\shared\libcarbonaux.dll