ARM Technical Support Knowledge Articles

COMPUTER SCREEN BLANKS WHEN BUILDING A PROJECT

Applies to: uVision IDE

Answer


Information in this article applies to:


SYMPTOMS

Translating a uVision project in Windows, the computer screen goes blank.

CAUSE

This is caused by Windows NT and 2000 executing command-line applications in full-screen mode. The compiler, assembler, and linker are all command-line programs. When the IDE runs these programs, NT switches to full-screen mode.

In Windows 95 and 98, this may be caused by settings for Microsoft VC++ that are incorrect. See below for more details.

RESOLUTION

In Windows NT...

  1. Open My Computer - Control Panel - Console Windows Properties.
  2. Under the Options Tab - Display Options you must select Window. This tells NT NOT to use the full screen mode when executing command line applications.

In Windows 2000...

  1. Open Start - Run... - regedit
  2. Set the variable FullScreen (found in: HKEY_CURRENT_USER / Console) to 0.

For Windows 95 and 98...

Microsoft has a similar problem report for VC++ that has solved this problem on some customers systems.

SEE ALSO

Article last edited on: 2004-12-16 04:11:33

Rate this article

[Bad]
|
|
[Good]
Disagree? Move your mouse over the bar and click

Did you find this article helpful? Yes No

How can we improve this article?

Link to this article
Copyright © 2011 ARM Limited. All rights reserved. External (Open), Non-Confidential