ARM Technical Support Knowledge Articles

CONFIGURING THE HTTP_DEMO PROGRAM

Applies to: RealView Real-Time Library

Answer


Information in this article applies to:


PROBLEM

While trying to run the HTTP_Demo program included with the RL-ARM product, the following command:

ping mcbstr9

gets no response from the MCBSTR9 board (or whatever board you use) and the HTTP_Demo server does not respond.

This problem occurs only if you use DHCP. If you disable DHCP in the HTTP_Demo and manually configure a Local IP Address, Subnet Mask, and Default Gateway IP Address, everything works.

CAUSE

Older HTTP_Demo configurations used an initial local IP address of 192.168.0.100 when DHCP was used. The local IP address should have been 0.0.0.0. This has been corrected in subsequent configurations.

If the local IP address configured in the HTTP_Demo matches the subnet address of your local network, DHCP will fail. For example, if your local subnet is 192.168.0.* and the local IP address in Net_Config.c for the HTTP_Demo program is 192.168.0.100, the DHCP server will not return an IP Address.

SOLUTION

Change the Local IP Address in Net_Config.c to 0.0.0.0. Then, the DHCP server will assign the Local IP Address, etc. normally.

SEE ALSO

Article last edited on: 2008-03-07 14:00:14

Rate this article

[Bad]
|
|
[Good]
Disagree? Move your mouse over the bar and click

Did you find this article helpful? Yes No

How can we improve this article?

Link to this article
Copyright © 2011 ARM Limited. All rights reserved. External (Open), Non-Confidential