ARM Technical Support Knowledge Articles

Which versions of RVD can I use with which versions of RVI?

Applies to: RealView Development Suite (RVDS), RealView ICE and Trace (RVI / RVT)

Answer

Prior to RVDS 4.0, the RVI software and RVD were shipped separately. The following matrix indicates which versions of the RVI software you can use with which versions of RVD. With regards to RVI firmware versions, we strongly recommended that you use the highest numbered RVI firmware version that ships with the RVI host software version that you are using.

RVD/RVI Compatibility Matrix
RVI v3.1 RVI v3.2 RVI v3.3 RVI v3.4 RVI v3.4.1 RVI v3.4.2 RVI v4.0  RVI v4.1 RVI v4.2
RVD v2.x No No No No No No No No No
RVD v3.0 Yes(a) No No No No No No No No
RVD v3.1 (any) Yes Yes Yes No No No No No No
RVD v4.0 No No Yes(b) Yes No No No No No
RVD v4.0.1 No No No Yes(b) Yes No No No No
RVD v4.0.2 No No No Yes Yes(b) No No No No
RVD v4.0.3 No No No No No Yes(b) No No No
RVD v4.1 No No No No No No Yes(c) Yes No
RVD v4.1.1 No No No No No No Yes Yes(c) No
RVD v4.1.2 No No No No No No No No Yes(c)

(a) NB: RVI 3.1 has CoreSight trace and Cortex-M1 debug support when used with RVD v3.1 but not when used with RVD v3.0.

(b) These versions are shipped together within releases of RVDS 4.0.x.

(c) This verion is shipped together within releases of RVDS 4.1.x.

NB: RVT2 works with RVD v3.1 patched, and requires RVI v3.2 or later. RVT2 works with RVD v4.0 and later.

Please also see: How do I find the Version and Build Numbers for my RVD/RVI tools?

Rate this article

[Bad]
|
|
[Good]
Disagree? Move your mouse over the bar and click

Did you find this article helpful? Yes No

How can we improve this article?

Link to this article
Copyright © 2011 ARM Limited. All rights reserved. External (Open), Non-Confidential