ARM Technical Support Knowledge Articles

Error: Please update GDBServer to v6.8 or later

Applies to: DS-5

Answer


Information in this knowledgebase article applies to:


SYMPTOM

Connecting to gdbserver fails with the error - "Please update gdbserver to v6.8 or later".

CAUSE

DS-5 Debugger makes use of features that are only available in gdbserver version 6.8 and later.

RESOLUTION

Upgrade your target to use gdbserver version 6.8 or later. Suitable versions are supplied with DS-5 for both Android and Linux platforms at the following location: <DS-5 installation folder>/arm/gdbservers. When using Android, you can alternatively copy the default gdbserver shipped in the ndk/prebuilt/android-arm/gdbserver folder.

Article last edited on: 2014-03-25 11:31:07

Rate this article

[Bad]
|
|
[Good]
Disagree? Move your mouse over the bar and click

Did you find this article helpful? Yes No

How can we improve this article?

Link to this article
Copyright © 2011 ARM Limited. All rights reserved. External (Open), Non-Confidential