ARM Technical Support Knowledge Articles

On what virtual platforms will my ARM development tools work?

Applies to: Tool Licensing (License Management)

Answer

The underlying FlexNet Licensing technology in ARM Compiler 5.03 and DS-5 v5.14 onwards now supports several virtual machine platforms, as specified in the table below. While Flexera, who provides FlexNet Licensing, documents these supported platforms, ARM has not tested and validated development tools like DS-5 running on these platforms.  Therefore ARM might not be able to support users running the ARM Compiler or DS-5 on virtual platforms, if they encounter compatibility issues.

The following development tools:

  • ARM Compiler v5.03 and later
  • DS-5 v5.14 and later
  • MDK-ARM v4.70 and later

should work for these virtual platforms:

  • VMware ESX 4.0 and 4.1/ESXi 4.0 and 4.1
  • Microsoft Hyper-V Server 2008 R2 (including SP1)

on the following operating systems:

  • Windows 32-bit platforms
    • Windows Server 2008,including SP2
    • Windows Vista,including SP1 (Ultimate) and SP2 (Business, Enterprise and Ultimate)
    • Windows 7 (Professional, Enterprise, Ultimate)
    • Windows Server 2003,including SP2 and R2
  • Windows 64-bit platforms
    • Windows Server 2008, including SP2 and R2
    • Windows Vista, including SP1 (Ultimate) and SP2 (Ultimate)
    • Windows 7 (Professional)
    • Windows Server 2003, including SP2 and R2
  • Linux 32-bit platforms
    • RedHat Enterprise Linux 4, 5, 6
    • SUSE Linux Enterprise 9, 10, 11
  • Linux 64-bit platforms
    • RedHat Enterprise Linux 4, 5, 6
    • SUSE Linux Enterprise 9, 10, 11

Related:

Article last edited on: 2014-04-01 13:37:07

Rate this article

[Bad]
|
|
[Good]
Disagree? Move your mouse over the bar and click

Did you find this article helpful? Yes No

How can we improve this article?

Link to this article
Copyright © 2011 ARM Limited. All rights reserved. External (Open), Non-Confidential