ARM Technical Support Knowledge Articles

Why am I getting a FlexNet -7,10015 license error?

Applies to: Tool Licensing (License Management)

Answer

FlexNet error -7,10015 can occur when the version of the FlexNet Publisher software running on your license server is older than the version required by the tool that is being invoked.

For example, unless your license server is running FlexNet 11.12.1.0 or later, invoking armcc version 5.05 will result in the following error:

Error: C9555E: License checkout for feature compiler5 with version 5.0201409 has
been denied by Flex back-end. Error code: -7
No socket connection to license server manager.
Feature: compiler5
License path: 8224@servername
FlexNet Licensing error:-7,10015
For further information, refer to the FlexNet Licensing documentation,
available at "www.flexerasoftware.com".
Product: ARM Compiler 5.05
Component: ARM Compiler 5.05 (build 41)
Tool: armcc [4d0eb9]

To resolve this issue, please download and install the latest version of the license server software from https://silver.arm.com/browse/BX002 (login/registration required).

See also:

Article last edited on: 2014-10-01 10:57:08

Rate this article

[Bad]
|
|
[Good]
Disagree? Move your mouse over the bar and click

Did you find this article helpful? Yes No

How can we improve this article?

Link to this article
Copyright © 2011 ARM Limited. All rights reserved. External (Open), Non-Confidential