ARM Technical Support Knowledge Articles

Why does RVD fail to start correctly with a TVS error message?

Applies to: RealView Developer Kit (RVDK) for OKI, RealView Development Suite (RVDS)

Answer

Sometimes when RVD is run for the first time after booting the PC the error message "Error TVS responding incorrectly or not at all" is displayed.  This is because the TVS application has not had time to initialise before RVD times out.

A quick workaround to prevent this happening is by starting TVS manually before starting RVD. To do this:

  • From the Windows Start menu select Start --> Run.
  • Enter the following text "tvs.exe -Vabs=tid" and click ok.

You should see the RVD target vehicle server running in the Windows system tray. Now launch RVD normally from the Windows start menu.

There are a number of factors which could be causing this problem.  Below are some suggestions on how to permanently resolve this issue without having to apply the workaround above:

  1. This problem may be related to networking issues in particular with floating licenses and how quickly the licenses are being 'checked-out'.  Therefore please also try some of the suggetions from the FAQ: 'Optimising license checkouts from a floating license server '.

  2. Another possible cause is having mapped network drives.  If you have any configured, try temporarily disabling them and then launching RVD.

  3. Create a batch file which launches tvs.exe, pauses, and then launches RVD.

Article last edited on: 2008-09-09 15:47:27

Rate this article

[Bad]
|
|
[Good]
Disagree? Move your mouse over the bar and click

Did you find this article helpful? Yes No

How can we improve this article?

Link to this article
Copyright © 2011 ARM Limited. All rights reserved. External (Open), Non-Confidential