ARM Technical Support Knowledge Articles

Multi-ICE 2.0/2.1 requires parallel port driver V1.8 or greater

Applies to: Multi-ICE

Answer

When starting up the Multi-ICE 2.0 or 2.1 Server, it may report "This version of the server requires parallel port driver V1.8 or greater - please reinstall". There are two circumstances where this may occur:

1) If a previous version of Multi-ICE did not uninstall properly, and has left an old version of the parallel port driver installed.
This driver (multiice.sys) is typically left in the directory <Windows install>System32drivers, e.g. CWINNTSystem32drivers.
To fix this, the Multi-ICE software should be uninstalled, then any occurrences of multiice.sys found and deleted, then Multi-ICE reinstalled.

2) In some circumstances, the Multi-ICE server may be unable to detect the PC's parallel port, causing the parallel port driver not to be loaded.
This can normally be avoided by changing the PC's parallel port setting in the BIOS, e.g from ECP to 8-bit bi-directional.

The next release of Multi-ICE will have a clearer error message for case 2): "Failed to open parallel port. The port may be in use.".

Article last edited on: 2008-09-09 15:47:29

Rate this article

[Bad]
|
|
[Good]
Disagree? Move your mouse over the bar and click

Did you find this article helpful? Yes No

How can we improve this article?

Link to this article
Copyright © 2011 ARM Limited. All rights reserved. External (Open), Non-Confidential