ARM Technical Support Knowledge Articles

What versions of the Java Runtime Environment are supported by the Eclipse plug-ins?

Applies to: RealView Development Suite (RVDS)

Answer

The Eclipse plug-ins for RVDS 3.0 and 3.1 are intended to work with Java Runtime Environments (JREs or JVMs) from version 1.4 onwards. However, some versions of the 1.4 JRE can result in fatal errors. Using the Eclipse IDE on RedHat Enterprise Linux 4, for example, with the IBM 1.4.2 JVM is likely to result in the following error:

JVMDG217: Dump Handler is Processing Signal 11 - Please Wait

On Windows XP and Windows 2000, this version of the JVM results in Eclipse crashing shortly after being invoked from Windows. 

The ARM distribution of Eclipse by default uses the first JRE found on the path.

ARM recommends using JRE from Java 5 or later.  For RVDS 3.0, on RedHat Enterprise Linux 3, ARM recommends that Eclipse users update their systems to Update 6.

Article last edited on: 2011-07-27 16:07:38

Rate this article

[Bad]
|
|
[Good]
Disagree? Move your mouse over the bar and click

Did you find this article helpful? Yes No

How can we improve this article?

Link to this article
Copyright © 2011 ARM Limited. All rights reserved. External (Open), Non-Confidential