ARM Technical Support Knowledge Articles

SPECIFYING USER LIB DIRECTORIES

Applies to: uVision IDE

Answer


Information in this article applies to:


QUESTION

I need to specifiy multiple directories for my libraries in my project. I have tried to do this in the File Extensions Tab in the Environment Setup for my Project. However, I receive the following error message:

*** FATAL ERROR 210: I/O ERROR ON INPUT FILE:
    EXCEPTION 0021H: PATH OR FILE NOT FOUND
    FILE: C:KEILC51LIB;CPROJECTSVTLHRTTARGETLIBC51S.LIB

I've tried separting the libraries with a semicolon (;), a comma, and a space, but to no avail.

How can I get uVision to recognize multiple library paths?

ANSWER

The linker does not search paths for user libraries. Instead, you must specify the complete path to the user library.

To do that, on the linker command line, add the library files as you would an object file: For example:

bl51 myfile.obj, mylib.lib to output.abs

In uVision, add a lib file to your project. The IDE sets all appropriate options to include it in the linkage.

Article last edited on: 2004-06-29 09:37:28

Rate this article

[Bad]
|
|
[Good]
Disagree? Move your mouse over the bar and click

Did you find this article helpful? Yes No

How can we improve this article?

Link to this article
Copyright © 2011 ARM Limited. All rights reserved. External (Open), Non-Confidential